Bug 33081 - Compile failure with -with-static_mono=no
Summary: Compile failure with -with-static_mono=no
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 4.2.0 (C6)
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Alex Rønne Petersen
URL:
Depends on:
Blocks:
 
Reported: 2015-08-13 19:11 UTC by Martin Potter
Modified: 2017-09-21 12:27 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Martin Potter 2015-08-13 19:11:03 UTC
We build Mono with the -with-static_mono=no for various reasons and it looks like this commit (https://github.com/mono/mono/commit/83e22234037a0e3560909b311811391efa117f22) broke the ability to compile with that flag. Attempting to build results in an undefined symbol error for mono_build_date.

Undefined symbols for architecture x86_64:
  "_mono_build_date", referenced from:
      _main in mono_sgen-main-sgen.o
Comment 1 Rodrigo Kumpera 2015-08-18 01:55:09 UTC
Hey Alexis,

Do you mind looking at this one?
Comment 2 Anton Voyl 2016-07-15 14:24:33 UTC
This problem remains with mono 4.4.1.0 (gcc 5.4).
I would be grateful to get any feedback about this issue.
Thank you for support, and regards.
Comment 3 Rodrigo Kumpera 2016-07-15 18:44:32 UTC
Hey João,

Can you fix this issue?
Comment 4 Anton Voyl 2016-07-16 20:24:16 UTC
Note that cross compiling shared also fails as reported in https://bugzilla.xamarin.com/show_bug.cgi?id=41340. Cross compiling is therefore not possible.

Thank you for any feedback.
Comment 5 Anton Voyl 2016-07-16 20:26:45 UTC
meh... I meant static, not shared
Comment 6 RQDQ 2016-09-07 14:43:33 UTC
Any workarounds available?
Comment 7 Martin Potter 2016-09-07 15:53:15 UTC
RQDQ,

You can comment out or remove this line https://github.com/mono/mono/blob/master/mono/mini/main.c#L213 which is what we are currently doing to compile.
Comment 8 Alex Rønne Petersen 2017-09-20 20:20:32 UTC
https://github.com/mono/mono/pull/5614