Bug 32918 - StackTrace() missing original exception - ExceptionDispatchInfo
Summary: StackTrace() missing original exception - ExceptionDispatchInfo
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib (show other bugs)
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: 4.2.0 (C6)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-08-10 13:35 UTC by Joe Pro
Modified: 2015-08-17 10:31 UTC (History)
6 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
repro (1.33 KB, text/plain)
2015-08-10 13:35 UTC, Joe Pro
Details

Description Joe Pro 2015-08-10 13:35:27 UTC
Created attachment 12434 [details]
repro

When building a StackTrace object from an exception re-thrown by ExceptionDispatchInfo, the original exception stacktrace is gone even though it is included in the Exception.  See simple repro attached.  When running repro on windows, against the .net framework, the full stacktrace is available.
Comment 1 Joe Pro 2015-08-10 13:47:10 UTC
The repro is clearly not for XI because I don't have access to it at the moment, but it should be easy to adapt it :)
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-08-11 07:07:47 UTC
@Marek. this looks like something in the BCL.
Comment 3 Marek Safar 2015-08-17 10:31:02 UTC
Fixed in master and 4.2 branch

Note You need to log in before you can comment on or make changes to this bug.