Bug 32846 - Attempting to JIT compile method '(wrapper runtime-invoke) <Module>:runtime_invoke_object_object_ob...
Summary: Attempting to JIT compile method '(wrapper runtime-invoke) <Module>:runtime_i...
Status: RESOLVED DUPLICATE of bug 31060
Alias: None
Product: iOS
Classification: Xamarin
Component: Mono runtime / AOT compiler (show other bugs)
Version: XI 8.10
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2015-08-06 21:57 UTC by Frank A. Krueger
Modified: 2015-08-07 03:38 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 31060

Description Frank A. Krueger 2015-08-06 21:57:11 UTC
App works in simulator, crashes on phone with a debug build.

        printfn "CAMERA p=%A, up=%A, dir=%A, dist=%A" cp cup cdir (p - cp).Length


System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> 

System.ExecutionEngineException: Attempting to JIT compile method '(wrapper runtime-invoke) <Module>:runtime_invoke_object_object_object_object_object_object_object_object_object_object (object,intptr,intptr,intptr)' while running with --aot-only. See http://docs.xamarin.com/ios/about/limitations for more information.

at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00044] in /Users/builder/data/lanes/1962/8b265d64/source/mono/mcs/class/corlib/System.Reflection/MonoMethod.cs:230
--- End of inner exception stack trace ---
at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x0005c] in /Users/builder/data/lanes/1962/8b265d64/source/mono/mcs/class/corlib/System.Reflection/MonoMethod.cs:238
at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in /Users/builder/data/lanes/1962/8b265d64/source/mono/mcs/class/corlib/System.Reflection/MethodBase.cs:114
at Microsoft.FSharp.Core.PrintfImpl+PrintfBuilder`3[System.IO.TextWriter,Microsoft.FSharp.Core.Unit,Microsoft.FSharp.Core.Unit].buildPlainFinal (System.Object[] args, System.Type[] argTypes) [0x0003d] in <filename unknown>:0
at Microsoft.FSharp.Core.PrintfImpl+PrintfBuilder`3[System.IO.TextWriter,Microsoft.FSharp.Core.Unit,Microsoft.FSharp.Core.Unit].buildPlain[String] (Int32 numberOfArgs, System.String prefix) [0x000c1] in <filename unknown>:0
at Microsoft.FSharp.Core.PrintfImpl+PrintfBuilder`3[System.IO.TextWriter,Microsoft.FSharp.Core.Unit,Microsoft.FSharp.Core.Unit].parseFormatString (System.String s, System.Type funcTy) [0x00060] in <filename unknown>:0
at Microsoft.FSharp.Core.PrintfImpl+PrintfBuilder`3[System.IO.TextWriter,Microsoft.FSharp.Core.Unit,Microsoft.FSharp.Core.Unit].Build[FSharpFunc`2] (System.String s) [0x00000] in <filename unknown>:0
at Microsoft.FSharp.Core.PrintfImpl+Cache`4[Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[System.Single,Microsoft.FSharp.Core.Unit]]]],System.IO.TextWriter,Microsoft.FSharp.Core.Unit,Microsoft.FSharp.Core.Unit].generate (System.String fmt) [0x00006] in <filename unknown>:0
at Microsoft.FSharp.Core.PrintfImpl+-cctor@1242-174[Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[System.Single,Microsoft.FSharp.Core.Unit]]]],System.IO.TextWriter,Microsoft.FSharp.Core.Unit,Microsoft.FSharp.Core.Unit].Invoke (System.String arg) [0x00000] in <filename unknown>:0
at System.Collections.Concurrent.ConcurrentDictionary`2[System.String,System.Tuple`2[Microsoft.FSharp.Core.FSharpFunc`2[Microsoft.FSharp.Core.FSharpFunc`2[Microsoft.FSharp.Core.Unit,Microsoft.FSharp.Core.PrintfImpl+PrintfEnv`3[System.IO.TextWriter,Microsoft.FSharp.Core.Unit,Microsoft.FSharp.Core.Unit]],Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[System.Single,Microsoft.FSharp.Core.Unit]]]]],System.Int32]].GetOrAdd (System.String key, System.Func`2 valueFactory) [0x00000] in <filename unknown>:0
at Microsoft.FSharp.Core.PrintfImpl+Cache`4[Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[System.Single,Microsoft.FSharp.Core.Unit]]]],System.IO.TextWriter,Microsoft.FSharp.Core.Unit,Microsoft.FSharp.Core.Unit].get (System.String key) [0x00000] in <filename unknown>:0
at Microsoft.FSharp.Core.PrintfImpl+Cache`4[Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[SceneKit.SCNVector3,Microsoft.FSharp.Core.FSharpFunc`2[System.Single,Microsoft.FSharp.Core.Unit]]]],System.IO.TextWriter,Microsoft.FSharp.Core.Unit,Microsoft.FSharp.Core.Unit].Get (Microsoft.FSharp.Core.PrintfFormat`4 key) [0x00037] in <filename unknown>:0
at Microsoft.FSharp.Core.PrintfModule.PrintFormatToTextWriterThen[Unit,FSharpFunc`2] (Microsoft.FSharp.Core.FSharpFunc`2 continutation, System.IO.TextWriter textWriter, Microsoft.FSharp.Core.PrintfFormat`4 format) [0x00000] in <filename unknown>:0
at Microsoft.FSharp.Core.PrintfModule.PrintFormatLineToTextWriter[FSharpFunc`2] (System.IO.TextWriter textWriter, Microsoft.FSharp.Core.PrintfFormat`4 format) [0x00007] in <filename unknown>:0
at Microsoft.FSharp.Core.ExtraTopLevelOperators.PrintFormatLine[FSharpFunc`2] (Microsoft.FSharp.Core.PrintfFormat`4 format) [0x00006] in <filename unknown>:0
at Driver.WorldViewController.setLocation (LatLng loc) [0x000a2] in /Users/fak/Dropbox/Projects/Driver/Driver/WorldView.fs:73
at Driver.WorldViewController.ViewDidLoad () [0x00057] in /Users/fak/Dropbox/Projects/Driver/Driver/WorldView.fs:103


	Target _CompileToNative:
		MTouch Task
		  AppBundleDir: bin/iPhone/Debug/Driver.app
		  AppManifest: bin/iPhone/Debug/Driver.app/Info.plist
		  Architecture: ARMv7, ARM64
		  CompiledEntitlements: obj/iPhone/Debug/Entitlements.xcent
		  Debug: True
		  EnableGenericValueTypeSharing: True
		  Entitlements: Entitlements.plist
		  ExecutableName: Driver
		  ExtraArgs: <null>
		  FastDev: False
		  I18n: <null>
		  IntermediateOutputPath: obj/iPhone/Debug/mtouch-cache
		  IsAppExtension: False
		  LinkMode: SdkOnly
		  MainAssembly: /Users/fak/Dropbox/Projects/Driver/Driver/bin/iPhone/Debug//Driver.exe
		  NativeReferences: <null>
		  OutputPath: bin/iPhone/Debug/
		  Platform: iPhone
		  Profiling: True
		  ProjectDir: /Users/fak/Dropbox/Projects/Driver/Driver
		  References:
		  SdkRoot: /Applications/Xcode.app/Contents/Developer
		  SdkVersion: 8.4
		  SymbolsList: obj/iPhone/Debug/mtouch-symbols.list
		  TargetFrameworkIdentifier: Xamarin.iOS
		  UseLlvm: False
		  UseRefCounting: False
		  UseSGen: True
		  UseThumb: False



=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: fce13fdd-e8e3-48ef-99f1-4acbb06f0240
Runtime:
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

=== Xamarin.Android ===

Version: 5.1.4.16 (Enterprise Edition)
Android SDK: /Users/fak/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.8.0_20-ea"
Java(TM) SE Runtime Environment (build 1.8.0_20-ea-b23)
Java HotSpot(TM) 64-Bit Server VM (build 25.20-b22, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 6.4 (7720)
Build 6E35b

=== Xamarin.Mac ===

Version: 2.0.2.35 (Enterprise Edition)

=== Xamarin.iOS ===

Version: 8.10.3.2 (Enterprise Edition)
Hash: 8b265d6
Branch: master
Build date: 2015-06-30 15:19:13-0400

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.10.4
Darwin muon.local 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64
Comment 1 Frank A. Krueger 2015-08-06 22:00:52 UTC
Basically, you can't use sprintf or printf with more than a couple args.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-08-07 03:38:59 UTC
Looks like a dup of #31060 (which is fixed for XI 8.12 / XI 9.0).

*** This bug has been marked as a duplicate of bug 31060 ***