Bug 32830 - Hiding navigation bar causes layouts to shift during navigation
Summary: Hiding navigation bar causes layouts to shift during navigation
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 1.4.4
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Samantha Houts [MSFT]
URL:
: 55846 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-06 11:35 UTC by David Brown
Modified: 2017-11-30 15:28 UTC (History)
17 users (show)

See Also:
Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Sample project (157.73 KB, application/zip)
2015-08-06 11:35 UTC, David Brown
Details

Description David Brown 2015-08-06 11:35:22 UTC
Created attachment 12386 [details]
Sample project

After calling NavigationBar.SetHasNavigationBar(this, false) in the constructor of Page1, navigating to Page2 causes the layout of Page1 to shift upward during the transition and create a white bar at the bottom. Navigating back from Page2 to Page1 causes the layout of Page2 to shift downward, though Page1 appears correctly.

I have attached a sample project to demonstrate this behavior. It occurs in the simulator and on my iPhone 5 running iOS 8.4.

Here is some additional information about my development system:

=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: 8c94bf96-c9b2-4ddc-a87c-1651d3fe4e5d
Runtime:
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

=== Xamarin.Android ===

Version: 5.1.4.16 (Starter Edition)
Android SDK: /Users/david/Development/SDKs/Android
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.8.0_05"
Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.5-b02, mixed mode)

=== Xamarin Android Player ===

Not Installed

=== Apple Developer Tools ===

Xcode 6.4 (7720)
Build 6E35b

=== Xamarin.iOS ===

Version: 8.10.3.2 (Indie Edition)
Hash: 8b265d6
Branch: master
Build date: 2015-06-30 15:19:13-0400

=== Xamarin.Mac ===

Not Installed

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.10.2
Darwin Davids-Mac-mini.local 14.1.0 Darwin Kernel Version 14.1.0
    Mon Dec 22 23:10:38 PST 2014
    root:xnu-2782.10.72~2/RELEASE_X86_64 x86_64
Comment 1 Paul DiPietro [MSFT] 2015-08-24 14:12:27 UTC
Confirming it appears to occur when using Forms 1.4.4.6392.
Comment 2 Alex 2016-03-14 11:06:13 UTC
There is still not fix in

Xamarin Studio: 5.10.2 (build 56)

Xamarin iOS: 9.4.1.25

Xamarin Android: 6.0.1.10

Does anyone have a work around for this? Doesn't look like this bug is getting fixed anytime soon.
Comment 3 Bright Lee 2016-08-06 12:27:16 UTC
still not fixed on forms 2.3
Comment 4 Philipp Sumi 2016-12-19 18:03:20 UTC
On Android, I'm seeing a similar (bad behavior):

* content of page1 is shifted down
* the navbar of page2 is displayed on top of page1's content
* the content of page2 replaces the content of page1.

Makes my app look like a prototype - it looks so bad that i reintroduced the navbar and sacrificied the clean look of my main/home page.
Comment 5 Rafael 2017-04-04 21:16:22 UTC
2017 and still not fixed?? Boys, pleaaase... Agree with everything what Philipp Sumi said. I am so sad right now.
Comment 6 David Ortinau [MSFT] 2017-04-25 12:11:19 UTC
Looks correct on iOS with Forms 2.3.4.231. https://www.screencast.com/t/81tAx4tBJ
Comment 7 NMackay 2017-04-25 12:28:30 UTC
It's Android where it's bad, it's okay in UWP as well.
Comment 8 David Brown 2017-04-25 13:22:53 UTC
In your screencast, the white bar doesn't appear at the bottom, but the layout of Page 1 still shifts upward before the transition. So it appears iOS is affected, as well.
Comment 9 Rafael 2017-04-25 15:07:58 UTC
On iOS still shifts, David. Try to put some content align bottom on your page 1.
Comment 10 Paul DiPietro [MSFT] 2017-05-01 17:52:41 UTC
*** Bug 55846 has been marked as a duplicate of this bug. ***
Comment 11 Samantha Houts [MSFT] 2017-05-11 00:52:26 UTC
@NMackay (or anyone else experiencing this issue in Android): Can you please attach a reproduction project that demonstrates this issue on Android? Are you using the AppCompat backend?

Thanks!
Comment 12 Samantha Houts [MSFT] 2017-06-08 17:13:19 UTC
https://github.com/xamarin/Xamarin.Forms/pull/962
Comment 13 Rui Marinho 2017-06-22 09:28:52 UTC
Should be fixed on 2.3.6-pre1
Comment 14 jmalbarran 2017-10-01 11:01:53 UTC
I confirm the same bug in Windows 10 UWP (mobile emulator and physical device).
Tested in 2.4.0.282
Comment 15 Juan José Requena Alcalá 2017-10-02 16:19:40 UTC
Confirmed on Android and iOS. 

Tested 2.4.0.282
Comment 16 Samantha Houts [MSFT] 2017-10-02 16:37:25 UTC
Juan José Requena Alcalá: Confirmed that the bug still exists or confirmed that it is now fixed?
Comment 17 Hakan 2017-11-30 15:28:30 UTC
I tested on Android. Although the transition got better overall, I have seen the following artifact: When transitioning from a page with navigation bar to a page with no navigation bar, I first see the title in the navigation bar change to reflect the title of the second page (which it shouldn't) and then the second page opens full screen (as it should).
(I tested on Samsung Galaxy S3, so it might be better if you could confirm it on a similar hardware. May be newer phones would be faster and make it harder to notice.)

Note You need to log in before you can comment on or make changes to this bug.