Bug 32767 - Watch App Info.plist UIDeviceFamily array incorrect
Summary: Watch App Info.plist UIDeviceFamily array incorrect
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS (show other bugs)
Version: 3.11 (C5)
Hardware: PC Mac OS
: Highest critical
Target Milestone: 3.11.4 (C5SR4)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-08-04 16:31 UTC by Aaron Sky
Modified: 2015-08-25 02:32 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Aaron Sky 2015-08-04 16:31:28 UTC
Build->Archive for Publishing adds invalid entry to Watch App Info.plist
UIDeviceFamily array. This file is in
Products/Applications/XXX.app/PlugIns/YYY.watchkitextension.appex/WatchApp.app/Info.plist.
It should have entry 4 for Watch, but Xamarin tooling adds 1. The app can be
uploaded to app store with this defect, but cannot be installed via TestFlight
(and likely by app review).

See:  https://bugzilla.xamarin.com/show_bug.cgi?id=30958

Environment Info
================
Microsoft Visual Studio Ultimate 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.6.00081

Installed Version: Ultimate

Xamarin   3.11.836.0 (ed5c750)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   5.1.5.3 (f98871a95a479f6d71b3067b7e5834d41fcb2118)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS   8.10.4.0 (6db87c53c073f4af2f5247fb738a27ea08c094fd)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration
Comment 1 PJ 2015-08-06 15:52:49 UTC
This will likely make it out soonest as a blog post entry, and then be included in C5SR4. Updating milestone.
Comment 2 Joaquin Jares 2015-08-07 09:34:20 UTC
This was fixed on Aug 4 in maccore and was bumped on XVS at that date. The build this was tested in is from Jul 29. Please retest with the latest.
Comment 3 Udham Singh 2015-08-07 14:56:09 UTC
I am not able to verify this issue due to issue https://bugzilla.xamarin.com/show_bug.cgi?id=32878

Thanks!
Comment 4 Mohit Kheterpal 2015-08-21 15:48:51 UTC
I am still getting the same issue with latest C5SR4 Builds:

Mac build Info: https://gist.github.com/NaqeebAnsari/782fd161b748d0735616
Windows build info: https://gist.github.com/NaqeebAnsari/782fd161b748d0735616

Here is the screencast for the same: http://www.screencast.com/t/UV5BZBaazIT
Comment 5 Joaquin Jares 2015-08-24 15:45:24 UTC
Fixed in Xamarin.iOS 8.10.5.25.
Comment 6 Arpit Jha 2015-08-25 02:32:01 UTC
I have checked this issue with XVS  3.11.893 + X.iOS 8.10.5.25  and its working fine.

I am able to upload iPA file of watchkitcatalog app to app store successfully.

Thanks