Bug 32739 - Getting Segmentation Fault (SIGSEGV)
Summary: Getting Segmentation Fault (SIGSEGV)
Status: RESOLVED NORESPONSE
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 4.0.0
Hardware: Other Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-08-04 05:42 UTC by Galute
Modified: 2018-04-05 19:57 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Galute 2015-08-04 05:42:08 UTC
This is happening intermittently but regularly.  The command being run is....

docker run --rm \
  -v "$ABS_CURDIR:/build" \
  --workdir /build \
  mono:4.0.0 \
  sh -c "nuget restore && xbuild /p:Configuration=Release"

where

ABS_CURDIR=`pwd`


As you can see we are running mono in a docker container so I'm not absolutely certain that it's mono and not docker causing the problem, but I suspect mono is more likely. It looks like it's the nuget restore stage that is failing.

and the log shows this...

Installing 'NUnit.Runners 2.6.4'.
Successfully installed 'NUnit.Runners 2.6.4'.
Installing 'Autofac 3.5.2'.
Installing 'Autofac.Owin 3.1.0'.
Installing 'Autofac.WebApi2 3.4.0'.
Installing 'log4net 2.0.3'.
Installing 'Autofac.WebApi2.Owin 3.2.0'.
Installing 'Microsoft.AspNet.Cors 5.2.3'.
Installing 'Microsoft.AspNet.WebApi.Client 5.2.3'.
Installing 'Microsoft.AspNet.WebApi.Core 5.2.3'.
Installing 'Microsoft.AspNet.WebApi.Owin 5.2.3'.
Installing 'Microsoft.AspNet.WebApi.OwinSelfHost 5.2.3'.
Installing 'Microsoft.Owin 3.0.1'.
Installing 'Microsoft.AspNet.WebApi.Cors 5.2.3'.
Installing 'Microsoft.Owin.Host.HttpListener 3.0.1'.
Installing 'Newtonsoft.Json 7.0.1'.
Installing 'Owin 1.0'.
Installing 'Microsoft.Owin.Hosting 3.0.1'.
Installing 'FluentValidation 5.6.2.0'.
Installing 'Autofac.Configuration 3.3.0'.
Installing 'NUnit 2.6.4'.
Installing 'Castle.Core 3.3.3'.
Installing 'Autofac.Extras.DynamicProxy2 3.0.7'.
Installing 'FakeItEasy 1.25.2'.
Installing 'Microsoft.AspNet.WebApi.WebHost 5.2.3'.
Installing 'Microsoft.AspNet.WebApi 5.2.3'.
Installing 'Microsoft.Owin.Testing 3.0.1'.
Successfully installed 'Autofac.Owin 3.1.0'.
Successfully installed 'Autofac 3.5.2'.
Successfully installed 'Autofac.WebApi2 3.4.0'.
Successfully installed 'Microsoft.AspNet.Cors 5.2.3'.
Successfully installed 'log4net 2.0.3'.
Stacktrace:


Native stacktrace:

	/usr/bin/cli() [0x4b20bc]
	/usr/bin/cli() [0x5086ee]
	/usr/bin/cli() [0x428f7d]
	/lib/x86_64-linux-gnu/libpthread.so.0(+0xf0a0) [0x7fa673c180a0]

Debug info from gdb:


=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================
Comment 1 Galute 2015-08-04 05:52:25 UTC
I should add that we run exactly the same command on our MacBooks (OS X Yosemite 10.10.4) and this has never happened.  It only ever happens running on out Linux build server
On that server:

cat /etc/issue

gives
Ubuntu 14.04.2 LTS \n \l

uname -a

gives

Linux ip-10-100-52-164 3.13.0-49-generic #81-Ubuntu SMP Tue Mar 24 19:29:48 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Comment 2 Galute 2015-08-04 05:57:58 UTC
.... and the number of 'Successfully installed' packages varies and appears random.
Comment 3 Zoltan Varga 2015-08-06 22:41:29 UTC
What mono version is this ? Please use the latest version from 
http://www.mono-project.com/download/#download-lin
Comment 4 Galute 2015-08-12 09:15:52 UTC
mono version is 4.0.0

We cannot just download latest as we are tied to latest version here https://github.com/mono/docker
Comment 5 Galute 2015-08-13 05:59:20 UTC
Actually, that is the wrong repo, it's here https://hub.docker.com/_/mono/
Comment 6 Ludovic Henry 2018-01-19 19:14:23 UTC
Can you still reproduce with latest Docker images? If so, could you please provide us with some stacktraces of the crash?
Comment 7 Ludovic Henry 2018-04-05 19:57:27 UTC
Please reopen if you can still reproduce. Thank you.