Bug 32720 - Debug inspection dialog crashed Monodevelop.
Summary: Debug inspection dialog crashed Monodevelop.
Status: RESOLVED DUPLICATE of bug 42029
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger (show other bugs)
Version: unspecified
Hardware: PC Linux
: Normal normal
Target Milestone: Future Cycle (TBD)
Assignee: Cody Russell
URL:
Depends on:
Blocks:
 
Reported: 2015-08-03 13:56 UTC by Matt
Modified: 2017-08-03 13:55 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Notice one triangle looks funny, that was the one that was clicked. (24.82 KB, image/png)
2015-08-03 13:56 UTC, Matt
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 42029

Description Matt 2015-08-03 13:56:53 UTC
Created attachment 12340 [details]
Notice one triangle looks funny, that was the one that was clicked.

Description of Problem:

Debug inspection dialog crashed Monodevelop.

Occasionally clicking the triangle to open an inspection dialog in the debugger completely crashes MD. See the attached screenshot. The little triangle that looks off, like it has extra pixels, was what was clicked. Note that MD is gray as it has crashed.

Steps to reproduce the problem:
1. Random, about three times a day. 
2. Click the triangle to open inspection dialog



Actual Results:

MD crashes.

Expected Results:

Dialog opens.

How often does this happen? 

About 1 in 20 clicks on the triangles.

Additional Information:

MonoDevelop
Version 5.10
Installation UUID: feaee481-7c2a-4781-a090-d6228809132d
Runtime:
	Mono 4.3.0 (master/53f9a3f Thu Jul 30 09:44:15 EDT 2015) (64-bit)
	GTK+ 2.24.23 (Ambiance theme)

Build Information
906638edf2923adaf47af9b1d390819560850e63

Operating System
Linux
Linux pharos 3.13.0-52-generic #86-Ubuntu SMP Mon May 4 04:32:59 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 David Karlaš 2015-08-18 04:35:52 UTC
Can you copy content of console output, since there should be exception causing crash?

Thank you.
Comment 2 Marcelo Saparrat 2015-09-20 16:28:50 UTC
Hi, I have the same problem. I copy here the log content:

ERROR [2015-09-20 17:07:56Z]: GLib-Critical: Source ID 16187 was not found when attempting to remove it
Stack trace: 
   at GLib.ToggleRef.g_object_remove_toggle_ref(IntPtr , GLib.ToggleNotifyHandler , IntPtr )
   at GLib.ToggleRef.Free()
   at GLib.Object.PerformQueuedUnrefs()
   at GLib.Timeout+TimeoutProxy.Handler()
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at MonoDevelop.Ide.IdeApp.Run()
   at MonoDevelop.Ide.IdeStartup.Run(MonoDevelop.Ide.MonoDevelopOptions options)
   at MonoDevelop.Ide.IdeStartup.Main(System.String[] args, MonoDevelop.Ide.Extensions.IdeCustomizer customizer)
   at MonoDevelop.Startup.MonoDevelopMain.Main(System.String[] args)
INFO [2015-09-20 17:10:06Z]: CodeTemplateService: No user templates, reading default templates.
Stacktrace:

  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Cairo.NativeMethods.cairo_fill (intptr) <0xffffffff>
  at Cairo.Context.Fill () <0x00013>
  at MonoDevelop.Components.PopoverWindow.OnExposeEvent (Gdk.EventExpose) <0x0023b>
  at Gtk.Widget.exposeevent_cb (intptr,intptr) <0x00082>
  at (wrapper native-to-managed) Gtk.Widget.exposeevent_cb (intptr,intptr) <0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) Gtk.Application.gtk_main () <0xffffffff>
  at Gtk.Application.Run () <0x0000b>
  at MonoDevelop.Ide.IdeApp.Run () <0x0000b>
  at MonoDevelop.Ide.IdeStartup.Run (MonoDevelop.Ide.MonoDevelopOptions) <0x01c4b>
  at MonoDevelop.Ide.IdeStartup.Main (string[],MonoDevelop.Ide.Extensions.IdeCustomizer) <0x00187>
  at MonoDevelop.Startup.MonoDevelopMain.Main (string[]) <0x0000f>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_int_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

	monodevelop() [0x4b23dc]
	monodevelop() [0x508a0e]
	monodevelop() [0x428fad]
	/lib/x86_64-linux-gnu/libpthread.so.0(+0x10d10) [0x7f34b695ad10]
	/usr/lib/x86_64-linux-gnu/libXrender.so.1(XRenderFindDisplay+0xf5) [0x7f34ab71e8e5]
	/usr/lib/x86_64-linux-gnu/libXrender.so.1(XRenderFillRectangle+0x36) [0x7f34ab71a466]
	/usr/lib/x86_64-linux-gnu/libcairo.so.2(+0x988e1) [0x7f34b09d08e1]
	/usr/lib/x86_64-linux-gnu/libcairo.so.2(+0x80b1c) [0x7f34b09b8b1c]
	/usr/lib/x86_64-linux-gnu/libcairo.so.2(+0x8258f) [0x7f34b09ba58f]
	/usr/lib/x86_64-linux-gnu/libcairo.so.2(+0x82b31) [0x7f34b09bab31]
	/usr/lib/x86_64-linux-gnu/libcairo.so.2(+0x26f30) [0x7f34b095ef30]
	/usr/lib/x86_64-linux-gnu/libcairo.so.2(+0x9dca0) [0x7f34b09d5ca0]
	/usr/lib/x86_64-linux-gnu/libcairo.so.2(+0x6f1d7) [0x7f34b09a71d7]
	/usr/lib/x86_64-linux-gnu/libcairo.so.2(+0x2f0dc) [0x7f34b09670dc]
	/usr/lib/x86_64-linux-gnu/libcairo.so.2(+0x28719) [0x7f34b0960719]
	/usr/lib/x86_64-linux-gnu/libcairo.so.2(cairo_fill+0x15) [0x7f34b0959825]
	[0x41594f50]

Debug info from gdb:

Could not attach to process.  If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user.  For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operación no permitida.
No threads.

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================
Comment 3 Kirill Osenkov 2017-05-15 21:35:35 UTC
Regarding funny triangles we have this:
https://bugzilla.xamarin.com/show_bug.cgi?id=54157
but it could be an unrelated issue.

Cody, does that GLib stack look familiar?
Comment 4 David Karlaš 2017-08-03 13:55:01 UTC
Same stacktrace of crash

*** This bug has been marked as a duplicate of bug 42029 ***