Bug 32689 - System.NullReferenceException at System.Net.ServicePoint.CheckAvailableForRecycling
Summary: System.NullReferenceException at System.Net.ServicePoint.CheckAvailableForRec...
Status: RESOLVED DUPLICATE of bug 32685
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 4.0.0
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-08-01 13:40 UTC by Ted
Modified: 2015-09-13 09:33 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 32685

Description Ted 2015-08-01 13:40:08 UTC
I have a program which consistently fails with the following exception when doing a CPU intensive operation using a Parallel operation.

Unhandled Exception:
System.NullReferenceException: Object reference not set to an instance of an object
  at System.Net.ServicePoint.CheckAvailableForRecycling (System.DateTime& outIdleSince) [0x00000] in <filename unknown>:0
  at System.Net.ServicePoint.IdleTimerCallback (System.Object obj) [0x00000] in <filename unknown>:0
  at System.Threading.Timer+Scheduler.TimerCB (System.Object o) [0x00000] in <filename unknown>:0

Seems similar to the bug below which has been resolved, but the stack trace is different.
https://bugzilla.xamarin.com/show_bug.cgi?id=19822

My system is Ubuntu server running on AMD64.
Mono version: (Stable 4.0.2.5/c99aa0c)

I believe the exception also used to happen on 3.9.

I can provide the application if necessary, but it may only happen on lower spec. processors depending on how long it takes to complete the task.
Comment 1 Marek Safar 2015-08-02 07:26:23 UTC

*** This bug has been marked as a duplicate of bug 32685 ***