Bug 32659 - The Camera Icon in the menu for taking snapshots is always disabled.
Summary: The Camera Icon in the menu for taking snapshots is always disabled.
Status: VERIFIED FIXED
Alias: None
Product: Profiler
Classification: Xamarin
Component: General (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2015-07-31 07:59 UTC by Marc Maurer
Modified: 2015-09-14 13:03 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Disabled Camara Icon in Xamarin profiler V0.18 (7.30 KB, image/jpeg)
2015-07-31 07:59 UTC, Marc Maurer
Details
Options - No Auto Snapshot (83.54 KB, image/png)
2015-09-02 14:22 UTC, Doug Jones
Details
Continued profiling (48.45 KB, image/png)
2015-09-02 14:23 UTC, Doug Jones
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Marc Maurer 2015-07-31 07:59:09 UTC
Created attachment 12316 [details]
Disabled Camara Icon in Xamarin profiler V0.18

Hi all,

My Question:
The Camera Icon in the menu is always disabled. I assume it is there for manually taking a snap shot by clicking it. Is there a way to enable it, or is this feature not implemented up to now?

Answer from Xamarin Developer:
Yes, it's for manually taking snapshots, so it should be enabled when live profiling (not when reading a static MLPD). So, under which circumstances is it disabled for you? Are you live profiling? What kind of app? If it shows disabled for you when live profiling, it's a bug.

My Answer:
I'm doing just live profiling. I have not used MLPD stuff up to now, so I think it is a bug. Icon is always disabled. I Never saw the icon enabled. I have an Android App build for Android >= 4.4 and a Google Nexus 5 mobile running Android 5.1.1. My App uses Android Support Library V4. Today I have installed Xamarin Profiler 0.19. Now the camera icon changed to a dot but it is still disabled.

I have also reported this issue first in Xamarin Proiler Forum under
https://forums.xamarin.com/discussion/46527/understanding-memory-allocation-list
but Xamarin Developer asked me to enter it in Bugzilla, so it will be not forgotten.

Best Regards
Marc
Comment 1 Dominique Louis 2015-08-27 15:42:07 UTC
Do you have autosnap shots ticked in the Tools->Options->Snapshots screen? If so, then this is by design the camera icon will not be enabled when autosnap shot is on.
Comment 2 Dominique Louis 2015-09-01 15:55:13 UTC
By design.
Comment 3 Doug Jones 2015-09-02 14:22:27 UTC
Created attachment 12721 [details]
Options - No Auto Snapshot

Started profiling my app. Opened Tools -> Options -> SnapShots and disabled the "Auto Snapshots" checkbox.
Comment 4 Doug Jones 2015-09-02 14:23:35 UTC
Created attachment 12722 [details]
Continued profiling

Profiler continues to run. The "record" button never enables and it still takes periodic snapshots on it's own.
Comment 5 Doug Jones 2015-09-02 14:24:03 UTC
I am experiencing the same issue as the original poster with the Windows version 0.20. Un-ticking the "Auto Snapshots" option does not enable the "Record" button and the profiler still performs periodic snapshots on it's own. In fact, I have never seen the button enabled with any configuration I have tried. I have attached a few screen shots to show the behavior. Please let me know if you need more information.
Comment 6 Rodrigo Moya 2015-09-10 04:03:19 UTC
Ok, I guess we are not clearing the setting when you disable it, so re-opening
Comment 7 Rodrigo Moya 2015-09-13 06:41:58 UTC
Fixed, will be in the next public build
Comment 8 Udham Singh 2015-09-14 13:03:47 UTC
I have checked this issue with XamarinProfiler.Windows.Installer.0.21-69 and I am able to take snapshots when option 'Auto Snapshots' is disabled. Hence I am closing this issue. 

Please refer the screencast : http://www.screencast.com/t/akKKcL540Trq

@Doug, please feel free to re-open this if you are still getting this issue with latest profiler build.

Thanks!