This is Xamarin's bug tracking system. For product support, please use the support links listed in your Xamarin Account.
Bug 32609 - PropertyInfo.CanWrite behavior difference from MS.NET
Summary: PropertyInfo.CanWrite behavior difference from MS.NET
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: CORLIB (show other bugs)
Version: 4.0.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
: 38461 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-30 10:11 UTC by Sandy Armstrong
Modified: 2016-02-04 17:25 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Sandy Armstrong 2015-07-30 10:11:24 UTC
Suppose you have:

class Super { public long A { get; private set; } }

class Sub : Super {}

On MS.NET, typeof(Sub).GetProperty("A").CanWrite returns false (unless you s/private/protected).

On Mono, it returns true.
Comment 1 Marek Safar 2015-07-31 03:44:19 UTC
Fixed in master
Comment 2 Rolf Bjarne Kvinge [MSFT] 2016-02-04 17:25:12 UTC
*** Bug 38461 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.