Bug 32552 - ListView + TableHeader + Pull Refresh + Grouped Data leads to strange UI behaviour
Summary: ListView + TableHeader + Pull Refresh + Grouped Data leads to strange UI beha...
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.4.3
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
: 33143 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-28 22:02 UTC by Stuart Campbell
Modified: 2015-10-09 10:37 UTC (History)
11 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:


Attachments
Repro project (160.00 KB, application/zip)
2015-07-28 22:03 UTC, Stuart Campbell
Details
Screenshot (27.16 KB, image/png)
2015-07-28 22:03 UTC, Stuart Campbell
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Stuart Campbell 2015-07-28 22:02:47 UTC
A pull down to refresh enabled listview exhibits strange UI behaviour when used on a list with grouping enabled. The group headers appear to "float" at a Y offset roughly equivalent to the size of the refreshing control. Repro and screenshot attached.
Comment 1 Stuart Campbell 2015-07-28 22:03:18 UTC
Created attachment 12257 [details]
Repro project
Comment 2 Stuart Campbell 2015-07-28 22:03:41 UTC
Created attachment 12258 [details]
Screenshot
Comment 3 Stuart Campbell 2015-07-28 22:15:50 UTC
Forgot to mention the tableheader - amended summary
Comment 4 Paul DiPietro [MSFT] 2015-08-17 12:31:01 UTC
*** Bug 33143 has been marked as a duplicate of this bug. ***
Comment 5 Rui Marinho 2015-09-24 16:50:48 UTC
Should be fixed in 1.5.1-pre1
Comment 6 Parmendra Kumar 2015-10-09 10:37:29 UTC
I have checked this issue with Xamarin.Forms 1.5.1-pre1 and its working fine.

Hence closing this issue.