Bug 32494 - Xamarin Studio on Windows does not support C# 6 features
Summary: Xamarin Studio on Windows does not support C# 6 features
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model (show other bugs)
Version: 5.9
Hardware: PC Mac OS
: Normal normal
Target Milestone: C6SR1
Assignee: Lluis Sanchez
URL:
: 33846 34583 34831 35395 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-27 15:01 UTC by Aaron Sky
Modified: 2015-12-17 14:10 UTC (History)
9 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Aaron Sky 2015-07-27 15:01:02 UTC
Builds are failing on latest stable of XS when trying to build code with C# 6.0 features. What version of MSBuild does XS on Windows use, what is its path, and if there is one, what is the plan for supporting and/or using Microsoft Build Tools 2015?
Comment 1 Sandy Armstrong [MSFT] 2015-07-29 14:32:00 UTC
I was recently looking into this, and it appears that we hard-code a preference for tools version 12 (VS2013):

https://github.com/mono/monodevelop/blob/master/main/src/core/MonoDevelop.Core/MonoDevelop.Projects.Formats.MSBuild/MSBuildProjectService.cs#L509

VS2015 is tools version 14.
Comment 2 Sandy Armstrong [MSFT] 2015-07-30 11:12:49 UTC
Michael pointed out that this can be worked around by adding this to your csproj:

<PropertyGroup Condition="'$(Platform)' != 'Unix'">
  <CscToolPath>$(MSBuildProgramFiles32)\MSBuild\14.0\Bin</CscToolPath>
</PropertyGroup>

Alternatively, you can set a CscToolPath system environment variable to the expanded value of that expression (which I have done, and it's working great now).
Comment 3 Mohit Kheterpal 2015-08-18 10:19:11 UTC
As per above discussion, marking this issue as Confirmed.
Comment 4 Peter Collins 2015-10-13 14:50:23 UTC
*** Bug 34831 has been marked as a duplicate of this bug. ***
Comment 5 Lluis Sanchez 2015-11-03 10:45:13 UTC
*** Bug 34583 has been marked as a duplicate of this bug. ***
Comment 6 Lluis Sanchez 2015-11-03 10:51:35 UTC
*** Bug 33846 has been marked as a duplicate of this bug. ***
Comment 7 Lluis Sanchez 2015-11-11 12:59:22 UTC
Fixed in 5.11.0.419 (a0c5725bfa4a07ff67a99a4bdff1f9cf8b638386)
Comment 8 Lluis Sanchez 2015-11-11 14:21:19 UTC
*** Bug 35395 has been marked as a duplicate of this bug. ***
Comment 10 xamarin-release-manager 2015-11-20 13:46:24 UTC
Fixed in version 5.10.0.881 (cycle6)

Author: Lluis Sanchez Gual
Commit: 5866862b44137081d88bdcb8184da0d00c1a8206 (mono/monodevelop)
Comment 11 Atin 2015-12-17 14:10:56 UTC
I have checked this issue with latest C6SR1 build i.e 
XamarinStudio-5.10.2.48_60e81d8fc403b35205259dc04e3f8cb60d6eeedd and now this issue is working fine. I have checked this issue with "Topeka" sample from bug
https://bugzilla.xamarin.com/show_bug.cgi?id=34831

Screencast for mac: http://www.screencast.com/t/SoocX1RU2GpK
Screencast for Windows: http://www.screencast.com/t/vVe2az5OKP

Hence I am closing this issue.