Bug 32461 - Immediate window 'application is running'
Summary: Immediate window 'application is running'
Status: CONFIRMED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger (show other bugs)
Version: Trunk
Hardware: PC Windows
: Normal normal
Target Milestone: master
Assignee: David Karlaš
URL:
Depends on:
Blocks:
 
Reported: 2015-07-27 05:06 UTC by Marius Ungureanu
Modified: 2015-08-06 05:08 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 32461 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Marius Ungureanu 2015-07-27 05:06:40 UTC
I manually paused an app by clicking the pause button in the debugger toolbar (this is windows).

Then, I tried inputting:
> new DateTime (DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day)

Got the following result:
> The expression can't be evaluated while the application is running.

I'd have expected the expression to be evaluated.
Comment 1 David Karlaš 2015-07-29 02:04:26 UTC
Problem here is that none of threads has stack frame which could be used for performing evaluation... And wrong message here: https://github.com/mono/monodevelop/blob/fbbcf655c40d0e3157771dc137887b1b70d793bf/main/src/addins/MonoDevelop.Debugger/MonoDevelop.Debugger/ImmediatePad.cs#L64

I will try to come up with some better solution then just better message.