Bug 32439 - Intellisense not working as expected in Visual Studio 2015
Summary: Intellisense not working as expected in Visual Studio 2015
Status: RESOLVED DUPLICATE of bug 32622
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General (show other bugs)
Version: unspecified
Hardware: PC Windows
: Normal major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-07-24 18:40 UTC by Rob DeRosa
Modified: 2015-08-11 17:50 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Attached project (174.82 KB, application/zip)
2015-07-24 18:41 UTC, Rob DeRosa
Details
screenshot (19.40 KB, image/png)
2015-07-24 18:41 UTC, Rob DeRosa
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 32622

Description Rob DeRosa 2015-07-24 18:40:50 UTC
From the customer:

"I'm seeing more issues on VS2015.  Oddly enough, they appear to be with intellisense and not with the build.  It builds and runs fine.  It seems the intellisense errors are false positives.  To illustrate I have attached a sample solution.

In the HelloXamarin portable project I created a ITest interface with a single method that returns a task.  In each of the platform specific projects I implement this task.  Intellisense thinks I need to add a reference to System.Threading.Tasks when specifying the interface I'm implementing.
https://www.dropbox.com/s/plx9bqv8cuoed93/image001.png?dl=0

This is just one example.  This occurs quite often in our existing solution with various types.

I also found multiple threads describing what I believe to be the same issue.

https://forums.xamarin.com/discussion/31112/new-project-out-of-the-box-so-to-speak-assembly-not-found-system-runtime
https://forums.xamarin.com/discussion/24190/missing-system-objectmodel-system-runtime-assemblies
https://forums.xamarin.com/discussion/1768/you-must-add-a-reference-to-assembly

I've tried several of the proposed solutions with no success.

Anyhow, I suspect you all have been trying VS2015, so perhaps there is a known fix or workaround I'm missing.

Thanks,"
Comment 1 Rob DeRosa 2015-07-24 18:41:21 UTC
Created attachment 12222 [details]
Attached project
Comment 2 Rob DeRosa 2015-07-24 18:41:40 UTC
Created attachment 12223 [details]
screenshot
Comment 3 Jason Smith [MSFT] 2015-08-05 15:17:44 UTC
This should be fixed in the 1.5.0-pre1 release of Xamarin.Forms
Comment 4 Parmendra Kumar 2015-08-06 11:10:26 UTC
I have checked this issue with attached sample project and I am still getting same behavior with Xamarin.Forms 1.5.0-pre1 .

Screencast: http://www.screencast.com/t/rMJkEpZr3itO

Hence reopen this issue.

Please follow the screencast and let me know if I have missed anything.

Environment info:

Windows 10

Microsoft Visual Studio Enterprise 2015
Version 14.0.23107.0 D14REL
Microsoft .NET Framework
Version 4.6.00079
Installed Version: Enterprise
Xamarin   3.11.666.0 
Xamarin.Android   5.1.4.16 
Xamarin.iOS   8.10.2.0
Comment 5 Brendan Zagaeski (Xamarin Team, assistant) 2015-08-11 17:50:16 UTC
I believe this is not one of the Xamarin.Forms IntelliSense issues, but rather a Roslyn C# PCL IntelliSense issue: Bug 32622.

I can verify that the workaround from Bug 32622, Comment 4 stops the problem for the test case in Comment 0 in my tests. I am accordingly marking this bug as a duplicate.


That said, there is still some on-going conversation about other remaining IntellIiSense issues in VS 2015.

See http://forums.xamarin.com/discussion/47943/upstream-release-microsoft-visual-studio-2015-rtm for the latest news.



## Version information (brief)

Windows 8.1 (64-bit) in VMWare Fusion 6.0.6

Microsoft Visual Studio Professional 2015
Version 14.0.23107.0 D14REL
Microsoft .NET Framework
Version 4.6.00081

Xamarin   3.11.836.0 (ed5c750)

*** This bug has been marked as a duplicate of bug 32622 ***