Bug 32407 - [HackWeek] XS gives no feedback to the user if the android emulator is corrupted
Summary: [HackWeek] XS gives no feedback to the user if the android emulator is corrupted
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in (show other bugs)
Version: 5.9
Hardware: PC Mac OS
: --- minor
Target Milestone: (C8)
Assignee: Greg Munn
URL:
: 36836 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-24 14:01 UTC by Greg Munn
Modified: 2016-08-12 14:12 UTC (History)
3 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Greg Munn 2015-07-24 14:01:52 UTC
Somehow I managed to corrupt my android emulators (the google ones). I think it was because I had some emulators defined, then removed most of the platform SDK (for some other unrelated testing), then reinstalled some of the platforms.

The emulator manager said a couple of the emulators were repairable, which I tried, but it seemed they weren't really repaired and would not start. However, from with XS, I couldn't tell. I would click run / debug and XS would flash up that it was starting the emulator and then stop.

It took some time for me to realise that it was actually trying to start the emulator.

What could be nice is if the emulator quits really quickly, that we detect this and display a message. At the moment, it assumes that the emulator was quit because of user intervention and does not display any message and this could be a little confusing for the user.
Comment 1 Greg Munn 2015-12-10 19:15:40 UTC
*** Bug 36836 has been marked as a duplicate of this bug. ***
Comment 3 Greg Munn 2016-07-21 15:57:56 UTC
FYI for myself, it's also possible to trigger this if you delete an emulator but google thinks it's in use and doesn't completely delete the emulator - it leaves the entry for the emulator but deletes the actual emulator. XS still thinks the emulator is there and when we run we get no indication that the emulator didn't run, the play button just turns back to the play button (from the stop button).
Comment 4 xamarin-release-manager 2016-07-21 17:28:24 UTC
Fixed in version 6.2.0.209 (master)

Author: Greg Munn
Commit: ec91995a891c4fe176379e26f7294e3178e84cd1 (xamarin/md-addins)
Included in Commit: baafad5b69f68333b940cc2e78ddd373b907cc60 (mono/monodevelop)
Comment 5 xamarin-release-manager 2016-08-10 19:08:47 UTC
Fixed in version 6.1.0.5326 (cycle8)

Author: Greg Munn
Commit: a0509d60d4d6602601a75e0661de0e5991c69d5d (xamarin/md-addins)
Included in Commit: da80f10c1a9e7de4903c987e67d7f18f0bbc7833 (mono/monodevelop)

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.