Bug 32377 - [Android] App crashes with SIGSEGV on 4.0.3 and 4.0.4 devices
Summary: [Android] App crashes with SIGSEGV on 4.0.3 and 4.0.4 devices
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler (show other bugs)
Version: 5.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Marek Habersack
URL:
Depends on:
Blocks:
 
Reported: 2015-07-23 17:26 UTC by Amalia
Modified: 2017-11-15 16:16 UTC (History)
6 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Amalia 2015-07-23 17:26:02 UTC
### Overview

When the app is run on the following devices, it crashes with the following error: Got a SIGSEGV while executing native code. This usually indicates a fatal error in the mono runtime or one of the native libraries used by your application.

Samsung Galaxy Tab 10" with Android version 4.0.4
Galaxy Nexus emulator with Android version 4.0.3

We have the .apk file from the customer, but can't reproduce the error on our machines, and the app is too complex to send to us. All the information here is directly from the customer.


### Steps to reproduce

1) Download DebugAndroid apk (in private comment 1), and sideload onto one of the devices listed.

2) Run the app on the device.


### Expected results

App runs without crashing


### Actual results

-App crashes. Error message: Got a SIGSEGV while executing native code. This usually indicates a fatal error in the mono runtime or one of the native libraries used by your application.
-See logs in private comment 1


### Additional information

Version information

Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.50938

Installed Version: Professional

LightSwitch for Visual Studio 2013 06177-004-0447006-02093
Microsoft LightSwitch for Visual Studio 2013

Team Explorer for Visual Studio 2013 06177-004-0447006-02093
Microsoft Team Explorer for Visual Studio 2013

Visual Basic 2013 06177-004-0447006-02093
Microsoft Visual Basic 2013

Visual C# 2013 06177-004-0447006-02093
Microsoft Visual C# 2013

Visual C++ 2013 06177-004-0447006-02093
Microsoft Visual C++ 2013

Visual F# 2013 06177-004-0447006-02093
Microsoft Visual F# 2013

Visual Studio 2013 Code Analysis Spell Checker 06177-004-0447006-02093
Microsoft® Visual Studio® 2013 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

Application Insights Tools for Visual Studio Package 1.0
Application Insights Tools for Visual Studio

ASP.NET and Web Tools 12.4.51016.0
Microsoft Web Developer Tools contains the following components:
Support for creating and opening ASP.NET web projects
Browser Link: A communication channel between Visual Studio and browsers
Editor extensions for HTML, CSS, and JavaScript
Page Inspector: Inspection tool for ASP.NET web projects
Scaffolding: A framework for building and running code generators
Server Explorer extensions for Microsoft Azure Websites
Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Microsoft Azure

ASP.NET Web Frameworks and Tools 2012.2 4.1.21001.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013 5.2.21010.0
For additional information, visit http://www.asp.net/

Common Azure Tools 1.3
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

JetBrains ReSharper Platform 6 Build 6.0.20141219.120158 on 2014-12-19 12:56:02Z
JetBrains ReSharper Platform package for Microsoft Visual Studio. For more information about ReSharper Platform, visit http://www.jetbrains.com/resharper. Copyright © 2015 JetBrains, Inc.

Microsoft Azure Mobile Services Tools 1.3
Microsoft Azure Mobile Services Tools

NuGet Package Manager 2.8.50926.663
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

Office Developer Tools for Visual Studio 2013 ENU 12.0.30626
Microsoft Office Developer Tools for Visual Studio 2013 ENU

PowerShell Tools 1.3
Provides file classification services using PowerShell

PreEmptive Analytics Visualizer 1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SAPReferenceManager 1.0
Manages References to Shared Projects

SQL Server Data Tools 12.0.41012.0
Microsoft SQL Server Data Tools

Windows Phone 8.1 SDK Integration 1.0
This package integrates the tools for the Windows Phone 8.1 SDK into the menus and controls of Visual Studio.

Workflow Manager Tools 1.0 1.0
This package contains the necessary Visual Studio integration components for Workflow Manager.

Xamarin 3.11.590.0 (5160db7)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android 5.1.3.1 (d419c934e6ce2113653ff4c40214e3a5d5a69440)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense 1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS 8.10.1.0 (fce006eae308515fc1eaf85fcc0f90699d9c7e8b)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration 1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration 1.0
Early preview of Xamarin Test Cloud integration
Comment 3 Brendan Zagaeski (Xamarin Support) 2015-07-30 23:14:05 UTC
I was able to reproduce _a_ crash with the test case `.apk` on ARM emulator, but the crash I'm seeing is "just" because the number of GREFs pass 2001, and Android kills the app. In other words, I'm not seeing the same crash demonstrated in the log file in comment 1.

I have accordingly sent some additional troubleshooting steps via the corresponding email support case to the original developers of the app so that they can try them under the original test conditions.

I will mark this bug as NEEDINFO while awaiting the response to those additional suggestions.
Comment 4 Jonathan Pryor 2015-08-01 09:15:32 UTC
I wonder if this is related to Bug #30722, though that one ls specific to x86.

Unrelated: how *useful* it is that the build fingerprint is "unknown":

> I/DEBUG   (  774): Build fingerprint: 'unknown'
Comment 5 Jon Douglas [MSFT] 2017-11-15 16:16:16 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Android. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.

Secondly it might be useful to check the respective GC Bridge Option and experiment with the respective bridge options given that the new default is Tarjan.

https://developer.xamarin.com/guides/android/advanced_topics/garbage_collection/#GC_Bridge_Options

Given the age of the bug, I am marking this as RESOLVED INVALID given the lack of reliable reproduction and reproduction details now 404 on Dropbox.

Note You need to log in before you can comment on or make changes to this bug.