Bug 32147 - Test suite fails when using two classes of different namespaces
Summary: Test suite fails when using two classes of different namespaces
Status: CONFIRMED
Alias: None
Product: iOS
Classification: Xamarin
Component: General (show other bugs)
Version: master
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-07-20 11:51 UTC by Cody Beyer (MSFT)
Modified: 2015-09-03 13:53 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 32147 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Cody Beyer (MSFT) 2015-07-20 11:51:42 UTC
### Description

The following sample app has two classes within different namespaces, each containing tests. One test suite will run, while the 2nd will fail with reflection errors

### Test Case

https://www.dropbox.com/s/05u4whfe0yervc5/Dummy.zip?dl=0

### Video

https://www.dropbox.com/s/jl7sg9jmz0yp7cu/TestFail.mov?dl=0

### Steps to Reproduce

1. Download sample
2. Deploy to iOS Simulator
3. Click on Dummy.exe
4. Click "Test1"
5. Click "Run All"
6. Click "Tests" to go back
7. Click "Test2"
8. Click "Run All"

### Expected Results

Both sets of tests should run and provide results

### Actual Results

The tests on step 8 fails due to reflection errors

### Version Info

=== Xamarin Studio ===

Version 5.9.5 (build 5)
Installation UUID: 14e9db9d-4a59-440f-8c5b-890f54ec8c58
Runtime:
	Mono 4.0.3 ((detached/429313d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400030013

=== Apple Developer Tools ===

Xcode 6.4 (7720)
Build 6E35b

=== Xamarin.iOS ===

Version: 8.10.4.10 (Business Edition)
Hash: c57a2c7
Branch: master
Build date: 2015-07-09 15:56:39-0400

=== Xamarin.Android ===

Version: 5.1.5.2 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.0.2.84 (Business Edition)

=== Build Information ===

Release ID: 509050005
Git revision: 8d5aa047f336e5129fff1b174a972021b087bd76
Build date: 2015-07-14 16:37:43-04
Xamarin addins: 3bc005cd1e150ae5f206c1cf76164f47f2f2b62c

=== Operating System ===

Mac OS X 10.10.4
Darwin Codys-Macintosh.local 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64
Comment 1 Arpit Jha 2015-08-07 02:55:26 UTC
I have checked this issue and able to reproduce this issue with the help of bug description.

Screencast: http://www.screencast.com/t/7yuidyiA

App output: https://gist.github.com/Arpit360/2c2b134b9e18294cbdfb

Environment info:
=== Xamarin Studio ===

Version 5.9.5 (build 7)
Installation UUID: 3d25a767-a003-4a7d-9f5e-e57987cf6cf0
Runtime:
	Mono 4.0.3 ((detached/102a681)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400030018

=== Xamarin.Android ===

Version: 5.1.5.3 (Enterprise Edition)
Android SDK: /Users/mac360_xamarin/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 6.3 (7569)
Build 6D570

=== Xamarin.iOS ===

Version: 8.10.4.45 (Enterprise Edition)
Hash: b94bc00
Branch: master
Build date: 2015-08-04 15:26:49-0400

=== Xamarin.Mac ===

Version: 2.0.2.35 (Enterprise Edition)

=== Build Information ===

Release ID: 509050007
Git revision: 676dac8a7ae1d4e6de624a0e029ae141cbc59028
Build date: 2015-07-22 13:25:06-04
Xamarin addins: d53d6eceb828422f3d4aff8547f2f6bab6c9ea58

=== Operating System ===

Mac OS X 10.10.4
Darwin mac360-xamarins-Mac-mini.local 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64
Comment 2 Cody Beyer (MSFT) 2015-09-03 13:53:53 UTC
Looked into this deeper, and this appears to be an issue with System.Reflection and/or iOS directly, as opposed to an issue with TestRunner. If it is determined to be a System.Reflection bug this could get recategorized as a Mono bug, but for the time being keeping it against Xamarin.iOS