Bug 32016 - Reference to libmonoruntimesgen.la in mono/unit-tests breaks with --disable-sgen
Summary: Reference to libmonoruntimesgen.la in mono/unit-tests breaks with --disable-sgen
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 4.0.0
Hardware: PC Other
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-07-16 07:52 UTC by Rainer Orth
Modified: 2015-07-16 07:52 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
proposed patch (948 bytes, application/octet-stream)
2015-07-16 07:52 UTC, Rainer Orth
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 32016 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Rainer Orth 2015-07-16 07:52:25 UTC
Created attachment 12067 [details]
proposed patch

When initially building mono 4.0.2.5 on 64-bit Solaris 11/x86, as described in bug 32015, I ran into another failure
in mono/unit-tests:

make[3]: *** No rule to make target `../metadata/libmonoruntimesgen.la', needed by `test-sgen-qsort'.  Stop.
make[3]: Leaving directory `/vol/obj/mono/mono-4.0.2/mono/unit-tests'

As a workaround, I replaced the unconditional reference to libmonoruntimesgen.la by a conditional one, as in the
attached patch.

  Rainer