Bug 31996 - AOT compiler fails if path to project has a comma
Summary: AOT compiler fails if path to project has a comma
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Mono runtime / AOT compiler (show other bugs)
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: João Matos
URL:
Depends on:
Blocks:
 
Reported: 2015-07-16 04:18 UTC by Rolf Bjarne Kvinge [MSFT]
Modified: 2015-07-21 14:10 UTC (History)
2 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Rolf Bjarne Kvinge [MSFT] 2015-07-16 04:18:58 UTC
Repro:
* Create new iOS project using a path with a comma.
* Build project for device.

AOT compilation fails with:

> AOT Compilation exited with code 1, command:
> MONO_PATH=/Users/rolf/Projects/c,m,a/concomma/concomma/obj/iPhone/Debug/mtouch-cache/64/Build /work/maccore/xcode7/maccore/_build/Library/Frameworks/Xamarin.iOS.framework/Versions/git/bin/arm64-darwin-mono-sgen --debug -O=gsharedvt -O=-float32  --aot=mtriple=arm64-ios,full,static,asmonly,direct-icalls,soft-debug,dwarfdebug,no-direct-calls,outfile="/Users/rolf/Projects/c,m,a/concomma/concomma/obj/iPhone/Debug/mtouch-cache/concomma.exe.arm64.s" "/Users/rolf/Projects/c,m,a/concomma/concomma/obj/iPhone/Debug/mtouch-cache/64/Build/concomma.exe"
> AOT : Unknown argument 'm'.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-07-16 04:23:49 UTC
The problem is that the AOT compiler uses g_strsplit to parse its arguments: https://github.com/mono/mono/blob/master/mono/mini/aot-compiler.c#L6549
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-07-16 04:26:22 UTC
Note: XI will quote paths/arguments to the AOT compiler that contains comma (maccore/3cd411db4428178db6b7577d33220e221dfd40ae), since otherwise there's no way for the AOT compiler to know if the comma means a new argument is coming or if it's in the path.
Comment 3 Rodrigo Kumpera 2015-07-16 12:01:36 UTC
Hi João,

Could you take a look at this one.
Comment 4 João Matos 2015-07-21 14:10:18 UTC
Should be fixed by https://github.com/mono/mono/commit/fc79543.

Notice (2018-05-21): bugzilla.xamarin.com will be switching to read-only mode on Thursday, 2018-05-25 22:00 UTC.

Please join us on Visual Studio Developer Community and GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs and copy them to the new locations as needed for follow-up. The See Also field on each Bugzilla bug will be updated with a link to its new location when applicable.

After Bugzilla is read-only, if you have new information to add for a bug that does not yet have a matching issue on Developer Community or GitHub, you can create a follow-up issue in the new location. Copy and paste the title and description from this bug, and then add your new details. You can get a pre-formatted version of the title and description here:

In special cases you might also want the comments:

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Note You need to log in before you can comment on or make changes to this bug.