Bug 31885 - Directory.EnumerateFiles returns incorrect result when searchPattern includes subdir
Summary: Directory.EnumerateFiles returns incorrect result when searchPattern includes...
Status: RESOLVED DUPLICATE of bug 42715
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib (show other bugs)
Version: 4.0.0
Hardware: PC All
: --- normal
Target Milestone: Untriaged
Assignee: Alexander Köplinger [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2015-07-13 13:06 UTC by Ryan Melena
Modified: 2016-11-29 15:42 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 42715

Description Ryan Melena 2015-07-13 13:06:44 UTC
Reproduce under Windows:

mkdir c:\temp\
mkdir c:\temp\test
echo $null >> c:\temp\test\file
csharp
using System.IO;
Directory.EnumerateFiles("c:\\temp","test\\file");

Result: { "c:\temp\file" }
Expected: { "c:\temp\test\file" }
Comment 1 Ryan Melena 2015-07-13 13:08:36 UTC
Believe the source of this issue may be the System.IO.MonoIO.FindFirst method.
Comment 2 Alexander Köplinger [MSFT] 2016-11-29 15:42:16 UTC

*** This bug has been marked as a duplicate of bug 42715 ***