Bug 31883 - System.InvalidProgramException on reference address store
Summary: System.InvalidProgramException on reference address store
Status: RESOLVED DUPLICATE of bug 36292
Alias: None
Product: Runtime
Classification: Mono
Component: JIT (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Alexander Kyte
URL:
Depends on:
Blocks:
 
Reported: 2015-07-13 12:28 UTC by Marek Safar
Modified: 2016-01-13 17:14 UTC (History)
5 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
test-1 (4.50 KB, application/x-msdownload)
2015-07-13 12:28 UTC, Marek Safar
Details

Description Marek Safar 2015-07-13 12:28:01 UTC
Created attachment 12003 [details]
test-1

mono test-1.exe

Unhandled Exception:
System.InvalidProgramException: Invalid IL code in B:M1<T_REF> (T_REF): IL_0002: stloc.0


No error on .net or with peverify
Comment 1 Andrea Canciani 2016-01-12 23:44:15 UTC
I hit the same exception on `stloc.s 4` in an F# library:

https://travis-ci.org/vslab/evreact/jobs/70061299
Comment 2 Zoltan Varga 2016-01-13 17:14:57 UTC

*** This bug has been marked as a duplicate of bug 36292 ***

Note You need to log in before you can comment on or make changes to this bug.