Bug 31875 - Android build fails
Summary: Android build fails
Status: RESOLVED DUPLICATE of bug 25086
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 5.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2015-07-13 09:02 UTC by Grigory (Playtika)
Modified: 2016-01-26 02:14 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
showing the path doesn't contain the path to the exe (17.06 KB, image/png)
2016-01-26 00:48 UTC, Chase Florell
Details
Agent Ransack dos2unix paths. (11.93 KB, image/png)
2016-01-26 00:49 UTC, Chase Florell
Details

Description Grigory (Playtika) 2015-07-13 09:02:26 UTC
_BuildApkBundle:
  [mkbundle stderr] "sh": C:android-ndk-r10etoolchainsarm-linux-androideabi-4.9prebuiltwindowsbinarm-linux-androideabi-as.exe: command not found
  [mkbundle stderr] ERROR: [Fail]
  [mkbundle stderr] 


Have a look at slashes.

  MonoAndroid Tools: C:\Program Files (x86)\MSBuild\Xamarin\Android\
  MonoAndroid Binaries: C:\Program Files (x86)\MSBuild\Xamarin\Android\
  Android Platform API level: 21
  TargetFrameworkVersion: v5.0
  Android NDK: C:\android-ndk-r10e\
  Android SDK: C:\android-sdk\
  Android SDK Build Tools: C:\android-sdk\build-tools\22.0.1\
  Java SDK: C:\Program Files (x86)\Java\jdk1.7.0_55\


Xamarin   3.11.666.0 (ebae43a)
Xamarin.Android   5.1.4.16 (5f55a9ef61c11b6ce0890bc91e4c71b1b92be214)
Comment 1 Grigory (Playtika) 2015-07-13 09:10:40 UTC
BTW: 3 other devs in my company have same issue
Comment 2 Jonathan Pryor 2015-07-15 12:01:42 UTC
Do your machines have dos2unix installed?

*** This bug has been marked as a duplicate of bug 25086 ***
Comment 3 Grigory (Playtika) 2015-07-15 13:00:05 UTC
Nope.

#25086 is hidden. 
This bug is closed as Resolved but i still have the issue.
Comment 4 Peter Collins 2015-07-22 16:21:25 UTC
@Grigory is a there git install in your path by chance?

Could you post the full diagnostic output for the build error you're encountering here?
http://developer.xamarin.com/guides/android/troubleshooting/troubleshooting/#Diagnostic_MSBuild_Output
Comment 5 Grigory (Playtika) 2015-07-28 12:18:56 UTC
YES!

Removing Git helps. 
But i want to use git from console. 

Fix that please :)

TLDR: Workaround is removing git from path
Comment 6 Peter Collins 2015-07-28 12:37:17 UTC
Having Git/bin in the path reproduces this because that bin folder also contains a dos2unix executable. This is indeed a duplicate of the private bug #25086.

Alternate possible workarounds (though I'm not sure what git functionality will break):
a. Remove the dos2unix.exe from Git/bin
b. Specify full paths to the git executables you need in your $PATH var

*** This bug has been marked as a duplicate of bug 25086 ***
Comment 7 Chase Florell 2016-01-26 00:47:33 UTC
Just bumping this issue. I've got dos2unix.exe installed in the Git/usr/bin directory, but that's not on my path. I get the same build errors.
Comment 8 Chase Florell 2016-01-26 00:48:15 UTC
Created attachment 14724 [details]
showing the path doesn't contain the path to the exe
Comment 9 Chase Florell 2016-01-26 00:49:08 UTC
Created attachment 14725 [details]
Agent Ransack dos2unix paths.
Comment 10 Peter Collins 2016-01-26 02:14:20 UTC
The fix for this issue went out with XA 6.0+ regardless of path contents, @Chase what version of Xamarin.Android are you using?

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.


Create a new report for Bug 31875 on Developer Community or GitHub if you have new information to add and do not yet see a matching report.

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments


Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.

Related Links: