Bug 31842 - "Refreshing" spinner is not present when first loading a ListView
Summary: "Refreshing" spinner is not present when first loading a ListView
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.4.3
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2015-07-10 17:22 UTC by Cody Beyer (MSFT)
Modified: 2017-02-16 12:36 UTC (History)
11 users (show)

Tags: ac
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Cody Beyer (MSFT) 2015-07-10 17:22:16 UTC
### Description

The following sample app contains a listview, where the desire is to have the "refreshing" spinner present while the data is initially loading into the ListView

### Test Case

https://www.dropbox.com/s/3ukjkfpoj1c9jmm/IndTest.zip?dl=0

### Steps to Reproduce

1. Download test case
2. Run in iOS Simulator

### Expected Results

The spinner should display while loading the data

### Actual Results

The spinner does not display

### Demo

It should behave the same as hitting the button on top of the form

### Version

=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: 28be6b98-f8c7-4ec8-af97-1e5cb1a4b44e
Runtime:
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

=== Apple Developer Tools ===

Xcode 6.4 (7720)
Build 6E35b

=== Xamarin.iOS ===

Version: 8.10.3.2 (Business Edition)
Hash: 8b265d6
Branch: master
Build date: 2015-06-30 15:19:13-0400

=== Xamarin.Mac ===

Version: 2.0.2.35 (Business Edition)

=== Xamarin.Android ===

Version: 5.1.4.16 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.2   (API level 17)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.10.4
Darwin Codys-MBP 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64
Comment 1 Parmendra Kumar 2015-07-13 07:12:31 UTC
I have checked this issue and getting same behavior mentioned in bug description.

Screencast: http://www.screencast.com/t/VgO88KsT0Wj

Application OutputLog: https://gist.github.com/Parmendrak/31c9126e26efde32a036
IDE Log: https://gist.githubusercontent.com/Parmendrak/2b5cc929b60452f7e3d1/raw/IDELog
Simulator Log: https://gist.github.com/Parmendrak/9c6d8ece3c383d13c8f0

Environment info:
Xamarin.Forms: 1.4.3.6376
Xamarin Studio5.9.4 (build 5)
Mono 4.0.2 ((detached/c99aa0c)
GTK+ 2.24.23 (Raleigh theme)
Xcode 6.2 (6776)
Xamarin.iOS: 8.10.3.2 (Enterprise Edition)
Xamarin.Android: 5.1.4.16 (Enterprise Edition)
Mac OS X 10.9.4
Comment 2 Chris King 2015-07-31 14:13:21 UTC
OnAppearing and the button click event both call BeginRefresh but the OnAppearing event doesn't cause the spinner to appear whereas the button does.
Comment 3 alan.spires 2015-08-04 17:05:38 UTC
this gonna get resolved in 1.4.5 pre1?
Comment 4 Jason Smith [MSFT] 2015-08-05 15:07:00 UTC
No
Comment 5 Rui Marinho 2015-09-24 16:51:21 UTC
Should be fixed in 1.5.1-pre1
Comment 6 Parmendra Kumar 2015-10-09 11:41:32 UTC
I have checked this issue with Xamarin.Forms 1.5.1-pre1 and its working fine.


Hence closing this issue.
Comment 7 Christer van der Meeren 2016-09-01 09:56:11 UTC
Was this fixed only for iOS? I experience the exact same problem on Android using Xamarin.Forms 2.3.1.114.

I simply downloaded the test case for this issue and upgraded the Xamarin.Forms package to 2.3.1.114. The initial loading animation appears on iOS, but not on Android.

(I came across this issue because I am experiencing this bug with another project I'm working on.)

Should I report this in a separate bug, or can this simply be re-opened?
Comment 8 Parmendra Kumar 2016-09-01 16:14:07 UTC
I am also able to reproduce this issue on Android with Xamarin.Forms 2.3.2.118-pre1. So I have file new issue for the same.
Bug: https://bugzilla.xamarin.com/show_bug.cgi?id=43943
Comment 9 Christer van der Meeren 2016-09-01 19:30:57 UTC
I tried visiting the new issue, but I get "You are not authorized to access bug #43943."
Comment 10 Parmendra Kumar 2016-09-01 19:35:27 UTC
Please try again to access the Bug.
Comment 11 Christer van der Meeren 2016-09-01 19:49:28 UTC
Thanks, works now.
Comment 12 stephen.machwirth 2016-10-07 09:17:09 UTC
Also getting the "You are not authorized to access bug #43943." issue.
Comment 13 Parmendra Kumar 2016-10-07 11:53:55 UTC
@Stephen,

You can again try to access bug #43943. and reported issue has been fixed on both environment iOS and Android in Xamarin.Forms 2.3.3.152-pre2.

Screencast: http://www.screencast.com/t/VLRToT6J

Thanks.
Comment 14 Ryan vd Wal 2016-12-22 21:07:35 UTC
I am using Xamarin.Forms 2.3.3.168 and coming in from the splash screen my listview doesn't show the loadig indicator. In the 'OnApearing' event I execute command (changeCanExecute code in place) that populates the viewmodel with the InotifyPropertyChanged stuff . At that particular time the Listview properties IsRefreshing and IsVisible are both true. Still the loading spinner for the view is nowhere to be seen. An activityindicator bound to the same IsLoading property works as advertised.
Comment 15 Michel Moorlag 2017-02-16 12:36:31 UTC
I am using Xamarin.Forms 2.3.3.180 and observing the same pattern. I have a page with listview that is loading data from a backend and only on IOS it is not showing the loading spinner when the page is loaded. If I pull to refresh I do see the spinner while it is calling the same async refresh function where the bound boolean property for "IsRefreshing" is set.