Bug 31141 - Change Entry keyboard type while typing
Summary: Change Entry keyboard type while typing
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS (show other bugs)
Version: 1.4.2
Hardware: All All
: Normal enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-06-16 03:54 UTC by Andrei.N
Modified: 2017-01-03 19:21 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Andrei.N 2015-06-16 03:54:06 UTC
Changing keyboard type when Entry is focused doesn't work.
The issue is that the EntryRenderer implementation doesn't call ReloadInputViews on the UITextView

See info and workaround:
http://forums.xamarin.com/discussion/43616/change-entry-keyboard-type-while-typing#latest
Comment 1 Andrei.N 2015-06-16 03:54:31 UTC
A similar issue is for WinPhone
Comment 2 adrianknight89 2016-10-11 07:36:09 UTC
See https://github.com/xamarin/Xamarin.Forms/pull/443
Comment 3 Samantha Houts [MSFT] 2017-01-03 19:21:41 UTC
Should be included in 2.3.4-pre2. Thank you!