Bug 31057 - Copy error between deploys: mdb in use by other process
Summary: Copy error between deploys: mdb in use by other process
Status: RESOLVED DUPLICATE of bug 26841
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android (show other bugs)
Version: unspecified
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-06-12 06:13 UTC by Rogier van der Hee
Modified: 2016-08-03 15:23 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 26841

Description Rogier van der Hee 2015-06-12 06:13:40 UTC
In the version: Xamarin.Android 5.1.4, Cycle 5 – Service Release 2

I regularly get the error between deploys of Android to a real device:

Error	29	Unable to copy file "<myproject>\bin\Debug\xx.dll.mdb" to "bin\Debug\xxx.dll.mdb". The process cannot access the file 'bin\Debug\xxx.dll.mdb' because it is being used by another process.	

I have to kill everything / reboot to be able to redebug
Comment 1 Sadik Ali 2015-06-18 06:19:27 UTC
I have checked this issue and unable to reproduce the reported behavior given in the bug description. Android project deploy successfully on device.

Screencast: http://www.screencast.com/t/Tg6cRyqBi0bg

Please let me know if I missed any step.

It would be great If you provide Ide Logs,Environment Info,Build Output,Screencast and sample project to reproduce the given behavior.

You get these information from

Ide Logs>> Help > Xamarin > Zip Xamarin Logs
Environment Info>> Help > About

Environment Info:

Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.50938

Installed Version: Professional

Xamarin   3.11.665.0 (7d53977)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   5.1.4.14 (a3f55306a55f005d2baf8e5d2c698230b22ab968)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS   8.10.2.0 (67b390d0d1bd741582cf7b7fd3ffea08583a3f83)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration
Comment 2 Peter Collins 2015-06-23 12:07:13 UTC
Appears to be a duplicate of Bug #26841

*** This bug has been marked as a duplicate of bug 26841 ***