Bug 30958 - Watch App Info.plist UIDeviceFamily array incorrect
Summary: Watch App Info.plist UIDeviceFamily array incorrect
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools (show other bugs)
Version: XI 8.10
Hardware: Macintosh Mac OS
: Highest critical
Target Milestone: Untriaged
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2015-06-09 22:31 UTC by t9mike
Modified: 2015-08-05 14:16 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
"Invalid UIDeviceFamily" from Application Loader (79.01 KB, image/png)
2015-07-30 18:26 UTC, Aaron Sky
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description t9mike 2015-06-09 22:31:11 UTC
Build->Archive for Publishing adds invalid entry to Watch App Info.plist UIDeviceFamily array. This file is in Products/Applications/XXX.app/PlugIns/YYY.watchkitextension.appex/WatchApp.app/Info.plist. It should have entry 4 for Watch, but Xamarin tooling adds 1. The app can be uploaded to app store with this defect, but cannot be installed via TestFlight (and likely by app review).

See https://forums.xamarin.com/discussion/42565/apple-watch-beta-build-does-not-install-from-testflight. 

=== Xamarin Studio ===

Version 5.9.3 (build 1)
Installation UUID: 2ef48581-52bf-43ad-b554-cca1ec408cf4
Runtime:
	Mono 4.0.1 ((detached/ed1d3ec)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400010044

=== Xamarin.Android ===

Version: 5.1.3.1 (Business Edition)
Android SDK: /Users/mmuegel/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
No Java runtime present, requesting install.

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 6.3.2 (7718)
Build 6D2105

=== Xamarin.Mac ===

Not Installed

=== Xamarin.iOS ===

Version: 8.10.1.64 (Business Edition)
Hash: e6ebd18
Branch: master
Build date: 2015-05-21 21:55:09-0400

=== Build Information ===

Release ID: 509030001
Git revision: 5a524e1726ed103fdd4fe37e0356f2b35466ce9d
Build date: 2015-06-02 16:35:08-04
Xamarin addins: 51957cfbd06be911b212671ad05c2c6221ac90f9

=== Operating System ===

Mac OS X 10.10.3
Darwin MacBook1 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 1 Tajinder Singh 2015-06-10 03:26:45 UTC
Checked, we are also getting UIdevice family entry 1 (for device) in info.plist at location:
▸ Library ▸ Developer ▸ Xcode ▸ Archives ▸ 2015-06-10 ▸ SingleViewApp90 6-10-15 12.34 PM.xcarchive ▸ Products ▸ Applications ▸ SingleViewApp90 ▸ PlugIns ▸ com.companyname.singleviewapp90.watchkitextension.appex ▸ SingleViewApp90WatchKitApp

after performing action Build->Archive for Publishing  for application.

screenshot: http://www.screencast.com/t/zYfbFwk4ndaw

supplement Info:
IDE log: https://gist.github.com/saurabh360/89fbb7841fe92a31027a#file-gistfile1-txt

Environment info:
=== Xamarin Studio ===

Version 5.9.4 (build 4)
Installation UUID: 642986ef-b668-4108-b6e5-f58c62d668b6
Runtime:
	Mono 4.0.2 ((detached/198235d)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020004

=== Apple Developer Tools ===

Xcode 6.3.2 (7718)
Build 6D2105

=== Xamarin.iOS ===

Version: 8.10.2.17 (Enterprise Edition)
Hash: 03fdc45
Branch: master
Build date: 2015-06-09 07:44:00-0400

=== Xamarin.Android ===

Version: 5.1.4.8 (Enterprise Edition)
Android SDK: /Users/360logica/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.0.2.16 (Enterprise Edition)

=== Build Information ===

Release ID: 509040004
Git revision: 0c8e73f6b66e066a642724a8241a0998b6329180
Build date: 2015-06-08 11:30:54-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.10.0
Darwin 360Logicas-MacBook-Pro.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-06-17 06:19:08 UTC
This has been fixed for Xamarin.iOS 8.12 (maccore/master: 1b1708dec19b343d20dbde8aa216b4888f8cc9cc).
Comment 3 Ian Leatherbury 2015-07-30 13:39:20 UTC
Can we add a miltestone to this? I am not able to upload to app store with watchkit: http://screencast.com/t/FQ0ThWGMd

Package Summary:
 
1 package(s) were not uploaded because they had problems:
	/var/folders/7q/kgfhnmc508z1f455mn9c0chr0000gn/T/7D62752F-A2B2-4195-A218-F97634BC8346/1024305012.itmsp - Error Messages:
		ERROR ITMS-90524: "Invalid UIDeviceFamily. The Info.plist of Apple Watch application 'NASA_POD.app/PlugIns/com.apod.watchkitextension.appex/NASA_PODWatchKitApp.app' contains an invalid UIDeviceFamily value of '1'."


=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: a94920a1-f856-4824-bfd3-9fdd755e5783
Runtime:
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

=== Xamarin.Android ===

Version: 5.1.4.16 (Enterprise Edition)
Android SDK: /Users/ianl/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Not Installed

=== Apple Developer Tools ===

Xcode 6.4 (7720)
Build 6E35b

=== Xamarin.Mac ===

Version: 2.0.2.35 (Enterprise Edition)

=== Xamarin.iOS ===

Version: 8.10.3.2 (Enterprise Edition)
Hash: 8b265d6
Branch: master
Build date: 2015-06-30 15:19:13-0400

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.10.4
Darwin ianl-mac.local 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64
Comment 4 Ian Leatherbury 2015-07-30 17:31:15 UTC
Additional information: I was actually able to upload this yesterday with Application Loader, but after submitting through iTunes Connect, I received the following response from Apple today: 

"Invalid UIDeviceFamily - The Info.plist of Apple Watch application 'NASA_POD.app/PlugIns/com.apod.watchkitextension.appex/NASA_PODWatchKitApp.app' contains an invalid UIDeviceFamily value of '1'."

I made an update today, and tried to upload again through Application Loader, and received the error message in Comment 3.
Comment 5 Aaron Sky 2015-07-30 18:25:48 UTC
I have been able to reproduce this error in Application Loader with XS 5.9.4.5, XI 8.10.3.2 and Xcode 6.4. Attached is the error in Application Loader I'm getting when I submit. I also compared the Info.plist in the Watch Extension to one in an old ipa that uploaded successfully back in June, and I was able to observe the same UIDeviceFamily value in both.

<key>UIDeviceFamily</key>
<array>
	<integer>1</integer>
</array>



Environment Info
------------------
=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: 0c38ad8a-9e2b-4b47-bc12-c639499efc27
Runtime:
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

=== Apple Developer Tools ===

Xcode 6.4 (7720)
Build 6E35b

=== Xamarin.iOS ===

Version: 8.10.3.2 (Business Edition)
Hash: 8b265d6
Branch: master
Build date: 2015-06-30 15:19:13-0400

=== Xamarin.Mac ===

Version: 2.0.2.35 (Business Edition)

=== Xamarin.Android ===

Version: 5.1.4.16 (Business Edition)
Android SDK: /Volumes/Needle/Users/aaronsky/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_79"
Java(TM) SE Runtime Environment (build 1.7.0_79-b15)
Java HotSpot(TM) 64-Bit Server VM (build 24.79-b02, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.10.4
Darwin Haunted-Mansion.local 14.4.0 Darwin Kernel Version 14.4.0
    Thu May 28 11:35:04 PDT 2015
    root:xnu-2782.30.5~1/RELEASE_X86_64 x86_64
Comment 6 Aaron Sky 2015-07-30 18:26:33 UTC
Created attachment 12309 [details]
"Invalid UIDeviceFamily" from Application Loader
Comment 7 Danish Akhtar 2015-07-31 03:23:10 UTC
Today, I have checked this issue with X.iOS 8.13.0.49, now this issue is not exists. We are not getting an error message when publishing watch kit application. Here is the screencast for the same: 
http://www.screencast.com/t/QFYcYdsl

We are also not getting UIdevice family entry 1 (for device) in info.plist
at location:
Products/Applications/XXX.app/PlugIns/YYY.watchkitextension.appex/WatchApp.app/Info.plist
after performing action Build->Archive for Publishing  for application. Screencast for the same: http://www.screencast.com/t/4hoCeID2WeZw

Hence closing this issue.

Please let us know, if we have to check something else.

Thanks

Environment info:=== Xamarin Studio ===

Version 5.9.5 (build 9)
Installation UUID: 46d4d4b6-9307-4ad8-8136-09022b256dbf
Runtime:
	Mono 4.0.3 ((detached/d6946b4)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400030020

=== Apple Developer Tools ===

Xcode 6.2 (6776)
Build 6C131e

=== Xamarin.iOS ===

Version: 8.13.0.49 (Enterprise Edition)
Hash: 0796dc8
Branch: master
Build date: 2015-07-30 12:04:53-0400

=== Xamarin.Mac ===

Version: 2.3.0.10 (Enterprise Edition)

=== Xamarin.Android ===

Version: 5.1.5.3 (Enterprise Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
		5.1    (API level 22)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 509050009
Git revision: b99cb19a1d3b15d8980c4616f13f837457e5b292
Build date: 2015-07-28 02:01:44-04
Xamarin addins: d53d6eceb828422f3d4aff8547f2f6bab6c9ea58

=== Operating System ===

Mac OS X 10.9.5
Darwin Danish.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 11 Rolf Bjarne Kvinge [MSFT] 2015-08-03 04:35:02 UTC
A hotfix has been released for this bug: https://releases.xamarin.com/ios-hotfix-for-watch-app-submission-technical-bulletin/