Bug 30883 - HttpClient will not complete NTLM handshake
Summary: HttpClient will not complete NTLM handshake
Status: RESOLVED DUPLICATE of bug 30869
Alias: None
Product: iOS
Classification: Xamarin
Component: BCL Class Libraries (show other bugs)
Version: XI 8.10
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL: http://forums.xamarin.com/discussion/...
Depends on:
Blocks:
 
Reported: 2015-06-08 00:47 UTC by Matthew Noel
Modified: 2015-06-08 03:54 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 30869

Description Matthew Noel 2015-06-08 00:47:19 UTC
In 8.10.x the HttpClient component appears to not complete the full NTLM handshake while executing an HttpRequest. The HttpResponse message is 401 Unauthorized, but what should happen is that additional back and forth messages should be sent in the background in order to successfully receive a 200 status code.

The last working version is 8.9.1.3. Making no other change beyond updating to any version of 8.10.x.x will cause the 401 Unauthorized error and the workaround is to downgrade back to 8.9.1.3.

This forum post describes the issue and indicates downgrading to 8.9.1.3 solves the issue for several people:
http://forums.xamarin.com/discussion/42647/problem-with-httpclient-after-updating-xamarin-ios
Comment 1 Marek Safar 2015-06-08 03:54:29 UTC

*** This bug has been marked as a duplicate of bug 30869 ***