Bug 30879 - IPv4Mask property produces a NotImplemented Exception
Summary: IPv4Mask property produces a NotImplemented Exception
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries (show other bugs)
Version: 5.2
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Marek Habersack
URL:
: 30880 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-07 18:02 UTC by Andrew Page
Modified: 2016-02-12 12:55 UTC (History)
5 users (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample Project Demonstrating issue. Cleaned, packages removed (30.50 KB, application/x-bzip2)
2015-06-07 18:02 UTC, Andrew Page
Details

Description Andrew Page 2015-06-07 18:02:39 UTC
Created attachment 11497 [details]
Sample Project Demonstrating issue.   Cleaned, packages removed

When attempting to access the UnicastIPAddressInformation IPv4Mask property you get a 'Not Implemented Exception"

Example:

	public void IPV4MaskIssueTest()
		{
			IPAddress mask = null ;
			foreach (NetworkInterface ni in NetworkInterface.GetAllNetworkInterfaces()) {
				foreach (UnicastIPAddressInformation uni in ni.GetIPProperties().UnicastAddresses) {	
					Console.WriteLine("ip mask = {0}", uni.IPv4Mask); // EXCEPTION
					mask = uni.IPv4Mask;
				}

			}
			Assert.IsNotNull(mask, "mask was not found");

		}
Comment 1 Naqeeb 2015-06-18 07:58:05 UTC
I have checked this issue with the help of attached sample and able to reproduce it successfully. I have also getting "System.NotImplementedException" .

Screencast: http://www.screencast.com/t/8tT5IgofWMa
Ide log: https://gist.github.com/Mohit-Kheterpal/8b7436a5880247b0226f
adb log: https://gist.github.com/Mohit-Kheterpal/36475d68b252d7d3a0c9
Application output: https://gist.github.com/Mohit-Kheterpal/e5e89abc8887cdd8463d

Environment info:
=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: 46d4d4b6-9307-4ad8-8136-09022b256dbf
Runtime:
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

=== Apple Developer Tools ===

Xcode 6.2 (6776)
Build 6C131e

=== Xamarin.Mac ===

Version: 2.0.1.64 (Business Edition)

=== Xamarin.iOS ===

Version: 8.10.2.21 (Business Edition)
Hash: 96f4a3a
Branch: master
Build date: 2015-06-12 18:49:46-0400

=== Xamarin.Android ===

Version: 5.1.4.14 (Business Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin Android Player ===

Not Installed

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.9.5
Darwin 360-MACMINIs-Mac-mini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 2 Shruti 2015-08-05 09:46:23 UTC
*** Bug 30880 has been marked as a duplicate of this bug. ***
Comment 3 Shruti 2015-08-05 10:04:40 UTC
I have checked this issue with latest master branch iOS build 8.13.0.71 . It is working fine. Hence, closing this issue.

Screencast: http://www.screencast.com/t/4dW149dlCQ

Environment Info:
=== Xamarin Studio ===

Version 5.9.4 (build 5)
Installation UUID: 67eaf3b4-f8a7-4ab4-a9df-3197350ca5dc
Runtime:
	Mono 4.0.2 ((detached/c99aa0c)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400020005

=== Apple Developer Tools ===

Xcode 6.3 (7569)
Build 6D570

=== Xamarin.Mac ===

Version: 2.1.0.1200 (Enterprise Edition)

=== Xamarin.iOS ===

Version: 8.13.0.71 (Enterprise Edition)
Hash: 475accd
Branch: master
Build date: 2015-08-04 13:59:26-0400

=== Xamarin.Android ===

Version: 5.1.5.3 (Enterprise Edition)
Android SDK: /Users/ixamarin78/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Build Information ===

Release ID: 509040005
Git revision: 8010a90f6e246b32364e3fb46ef2c9d1be9c9a2b
Build date: 2015-06-08 16:52:06-04
Xamarin addins: 7e93e9c3503f28770f23ce1b7eafd829919f18e8

=== Operating System ===

Mac OS X 10.10.3
Darwin XamnewiMac.local 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 4 Andrew Page 2015-08-08 09:32:32 UTC
Fixed on the 'Enterprise Editions' but the problem still persists in the 'Indie' Editions as currently updated.

Xamarin.iOS
Version: 8.10.3.2 (Indie Edition)

Xamarin.Android
Version: 5.1.4.16 (Indie Edition)


which seem to be behind your

=== Xamarin.iOS ===

Version: 8.13.0.71 (Enterprise Edition)

=== Xamarin.Android ===

Version: 5.1.5.3 (Enterprise Edition)


There appear to be no pending updates.   When will these packages be made available?
Comment 5 Andrew Page 2015-10-29 18:18:56 UTC
Still not fixed in the Indie edition.   Still producing a 'NotImplimented' exception in ios


Xamarin.iOS
Version: 9.1.0.27 (Indie Edition)
Hash: 1f068b4
Branch: master
Build date: 2015-10-27 18:59:21-0400


Could you just be honest with us and say "you have to buy the enterprise edition"?
Comment 6 Jonathan Pryor 2015-10-30 13:03:09 UTC
@Shruti: Xamarin.Android != Xamarin.iOS. Just because it works on iOS doesn't mean that it works on Android, and this bug was filed against Xamarin.Android (see Product and Component).

Comment #3 is thus very confusing.
Comment 7 Marek Habersack 2015-10-30 13:09:46 UTC
@andy saying what you suggest would be the contradiction of honesty, since
there is no difference in BCL between Xamarin editions. The code in question
was implemented on June 6th 2015, after your bug was filed and will be part of
the next product release based on Mono 4.2. See
https://github.com/mono/mono/blob/mono-4.2.0-branch/mcs/class/System/System.Net.NetworkInformation/UnicastIPAddressInformation.cs#L153
Comment 8 Andrew Page 2015-10-31 10:30:56 UTC
I went through the trouble of replicating the bug.
Your guy replied with barely more than a "works for me." and a list of "Enterprise" tagged versions.(Comment 3)
I reply back with the Indie configurations(Comment 4) and that the problem persists and a simple request to know when these fixes will be released to the "Indie" editions.

(10 weeks go by)

I ask if I have to upgrade to the "Enterprise" edition in order to see these fixes, since as stated in comment three, they appear to be fixed in the Enterprise edition yet do not appear to be fixed in the latest updates to the Indie editions 10 weeks and several updates later.

Comment 7 states this is fixed in Mono 4.2, although the Indie Editions(can't speak for the Enterprise Editions) seems to only carry 4.0.5

A bit more searching shows that Mono 4.2  appears in the  ALPHA channel of the mono-project (along with some vague notations that System.Net.NetworkInformation fixed).   That would have been a useful clarification.   

As would the inferred policy that bugs are 'fixed' when they appear in someone else's alpha release as opposed to the software that is actually released.  



=== Xamarin Studio ===

Version 5.9.8 (build 0)
Installation UUID: 73e353b6-d62c-4087-83a0-cbff94bc27cb
Runtime:
	Mono 4.0.5 ((detached/1d8d582)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400050001
Comment 9 Marek Habersack 2015-10-31 10:55:29 UTC
(In reply to comment #8)
> I went through the trouble of replicating the bug.
> Your guy replied with barely more than a "works for me." and a list of
> "Enterprise" tagged versions.(Comment 3)
> I reply back with the Indie configurations(Comment 4) and that the problem
> persists and a simple request to know when these fixes will be released to the
> "Indie" editions.
You focused on editions, which have nothing whatsoever to do with the version, and not on the versions themselves. Your Indie editions were older versions than his enterprise ones. And the version alone has any meaning, as I explained previously.

> 
> (10 weeks go by)
> 
> I ask if I have to upgrade to the "Enterprise" edition in order to see these
> fixes, since as stated in comment three, they appear to be fixed in the
> Enterprise edition yet do not appear to be fixed in the latest updates to the
> Indie editions 10 weeks and several updates later.
That was your, incorrect, assumption. The release process takes time and, again, it has nothing to do with the edition.

> 
> Comment 7 states this is fixed in Mono 4.2, although the Indie Editions(can't
> speak for the Enterprise Editions) seems to only carry 4.0.5
Again, nothing to do with editions. All the currently *released* *versions* are based on 4.0.5 and the *upcoming* *versions* will be based on 4.2
 
> A bit more searching shows that Mono 4.2  appears in the  ALPHA channel of the
> mono-project (along with some vague notations that
> System.Net.NetworkInformation fixed).   That would have been a useful
> clarification.   
Source for Mono is available and all it takes is a quick look at the sources to see when/if/where some code was added and modified. The clarification you suggest above would have changed nothing since release of any current version of *desktop* Mono has nothing to do with the release schedule of Xamarin products (nor with versions of Mono used in them). They *may* be the same, but they don't *have* to be the same.
 
> As would the inferred policy that bugs are 'fixed' when they appear in someone
> else's alpha release as opposed to the software that is actually released.  
The bugs are fixed when a fix is committed to the repository in question. The fix is followed by the release process that leads to the users of a product obtaining the code with the fix. The bug report is concerned with the fix itself, not the release process.

> 
> 
> 
> === Xamarin Studio ===
> 
> Version 5.9.8 (build 0)
> Installation UUID: 73e353b6-d62c-4087-83a0-cbff94bc27cb
> Runtime:
>     Mono 4.0.5 ((detached/1d8d582)
>     GTK+ 2.24.23 (Raleigh theme)
> 
>     Package version: 400050001
Comment 10 jobertodinizjunior 2016-02-12 12:55:05 UTC
I've installed mono 4.2.2.30 on Linux and still get NotImplementedException for IPv4Mask property.

Is this really fixed?

Note You need to log in before you can comment on or make changes to this bug.