Bug 30869 - HttpClient authentication not working
Summary: HttpClient authentication not working
Status: VERIFIED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Net.Http (show other bugs)
Version: 3.8.0
Hardware: PC Windows
: High major
Target Milestone: 4.0.4 (C5SR4)
Assignee: Marek Safar
URL:
: 30883 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-06 13:03 UTC by Rob DeRosa
Modified: 2015-08-24 10:30 UTC (History)
9 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Marek Safar 2015-06-08 03:54:29 UTC
*** Bug 30883 has been marked as a duplicate of this bug. ***
Comment 2 Marek Safar 2015-06-08 05:01:01 UTC
Could you provide repro which would help us track the issue?
Comment 3 Jordi Corominas 2015-06-08 07:06:37 UTC
More information can be found here: http://forums.xamarin.com/discussion/42647/problem-with-httpclient-after-updating-xamarin-ios

Unfortunatelly we can't provide a repo, but we posted part of the code on this post.
Comment 6 Marek Safar 2015-06-09 12:36:05 UTC
I can reproduce the issue now
Comment 7 Rob DeRosa 2015-06-10 12:02:32 UTC
Some additional findings from one of the reporters of the issue:

"We also discovered that neither HttpClientHandler nor old good HttpWebRequest classes work when HTTP “HEAD” verb is used and server has NTLM security option enabled. Still the same 401.2 Unauthorized and no further hand-shake process established. Symptoms are the same.
This issue sorely breaks our network traffic optimization idea which is of very high priority for us!"
Comment 8 Marek Safar 2015-06-10 15:25:11 UTC
Fixed in master/Mono 4.2.

Do you need this in 4.0?
Comment 9 Matthew Noel 2015-06-11 09:53:22 UTC
What version of Xamarin.iOS corresponds to master/Mono 4.2 as opposed to 4.0?
Comment 10 Marek Safar 2015-06-16 07:18:28 UTC
There isn't any Xamarin.iOS version based on Mono 4.2 available but I proposed this to be included in SR3 (next service release update) of the latest Xamarin.iOS
Comment 12 Jim Bennett 2015-08-04 15:45:26 UTC
Is there a release version for this fix yet?
Comment 13 PJ 2015-08-04 15:56:29 UTC
Hi Jim,

This was just released today on the release blog [1], and will make it to the updater channels at the end of the month.

[1] https://releases.xamarin.com/ios-hotfix-for-watch-app-submission-technical-bulletin/
Comment 14 Arpit Jha 2015-08-24 10:30:31 UTC
I have checked this issue with latest C5SR4 and C5 trunk and sample repo attached in trello card :

https://trello.com/c/wrYIjqtU/10-mono-xi-bug-30869-httpclient-authentication-not-working

responcecode getting ’Not Found’  with both builds, As per Oleg Comment on trello card this is expected behaviour. 

C5SR4 monotouch-8.10.5.25_c22cea6554d9519559899c96e40e6ef168ab6492  :  http://www.screencast.com/t/pGcSf5CwZzBb

C5 trunk : monotouch-8.10.5.25_b5808d382e134f01e699480d722116c22781c2bc :  http://www.screencast.com/t/5bnNphIVC20

I have also updated the trello card.

Thanks