Bug 30755 - using static does not import const members when static class is defined in separate assembly
Summary: using static does not import const members when static class is defined in se...
Status: RESOLVED DUPLICATE of bug 28976
Alias: None
Product: Compilers
Classification: Mono
Component: C# (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2015-06-03 17:06 UTC by David Siegel
Modified: 2015-06-04 10:49 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 28976

Description David Siegel 2015-06-03 17:06:03 UTC
In library:

  public static class Goodies {
    public const int Zero = 0;
    public static readonly int One = 1;
  }

In client project:

  using static MyLib.Goodies;

  // Zero is not found and compile failes
  // One is found just fine

The same class copied to the client project allows importing the const.
Comment 1 Marek Safar 2015-06-04 10:49:50 UTC

*** This bug has been marked as a duplicate of bug 28976 ***