Bug 30561 - Setting HttpContent in System.Net.Http does not set ContentLength header.
Summary: Setting HttpContent in System.Net.Http does not set ContentLength header.
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Net.Http (show other bugs)
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2015-05-28 18:38 UTC by sornakumar
Modified: 2015-07-09 11:53 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description sornakumar 2015-05-28 18:38:31 UTC
var content = new StreamContent(new MemoryStream(Encoding.UTF8.GetBytes("Hello, World")));
var length = content.Headers.ContentLength;
foreach (var header in content.Headers)
{
  if (header.Key == "ContentLength")
  {
    Console.WriteLine("Content Length was set");
    break;
  }
}

The above code prints "Content Length was set" in .NET but does not do the same in Mono. The reason being - the ContentLength property in HttpContentHeaders sets the header in .NET but it just returns the value in mono: https://github.com/mono/mono/blob/master/mcs/class/System.Net.Http/System.Net.Http.Headers/HttpContentHeaders.cs#L70
Comment 1 Chris Hamons 2015-07-02 11:32:28 UTC
This appears to be a Mono Class Library bug. 

@sornakumar MonoMac is for the open source bindings to OS X. I'll move it to the correct product, but if your example doesn't contain "using MonoMac;" please consider filing it against another product.
Comment 2 Marek Safar 2015-07-09 11:53:46 UTC
Fixed in master