Bug 30496 - iOS WebService Sample Project Won't Run under Xamarin.iOS 8.10.0.303 (works under 8.9.1.3)
Summary: iOS WebService Sample Project Won't Run under Xamarin.iOS 8.10.0.303 (works u...
Status: RESOLVED DUPLICATE of bug 29211
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples (show other bugs)
Version: master
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Rustam Zaitov
URL:
Depends on:
Blocks:
 
Reported: 2015-05-27 07:02 UTC by Philippe Faucon
Modified: 2015-05-27 09:02 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 29211

Description Philippe Faucon 2015-05-27 07:02:41 UTC
To Reproduce:
- Download code sample from:
-- http://developer.xamarin.com/guides/cross-platform/application_fundamentals/web_services/Resources/WebServiceSamples.zip
- unzip/build with Xamarin.iOS 8.10.0.303
- Run on the simulator (I tested with iPhone 6 iOS 8.3)

Expected bug:
- Simulator disconnects after a short period launching
- If launching directly from the simulator the app crashes and generates a bugsplat

Expected working behavior:
- App launches into a table-view with a search bar, user can search on default text to get results

-----------

I recently upgraded to the new Xamarin.* and it broke soap requests in my project. Looking for a minimum example of a Xamarin Soap request project I found:
http://developer.xamarin.com/guides/cross-platform/application_fundamentals/web_services/ -> download sample code

This project seems to compile but does not run from Xamarin Studio (mac). From the studio it begins to launch, and then fails, giving the following "application output" gist:
https://gist.github.com/pfaucon/a8195ca4286ae905e6aa

When running the app on the simulator it generates a standard OSX crash shown at this gist:
https://gist.github.com/pfaucon/db9fe66b8f961be69556


-------- BROKEN UNDER -------
info:
Mac OSX - 10.10.2
Xcode 6.3
Xamarin
.studio - 5.9.1
.Android - 5.1.1.0 (indie)
.iOS - 8.10.0.303 (indie)

----------- WORKS WITH ---------
Xamarin.iOS
Version: 8.9.1.3 (Indie Edition)
Hash: f7736a4
Branch: 
Build date: 2015-04-09 04:22:08-0400
(all other info same, .studio as well)

Created a forum post as well:
http://forums.xamarin.com/discussion/42175/ios-webservice-sample-project-wont-run-under-xamarin-ios-8-10-0-303-works-under-8-9-1-3#latest
Comment 1 Rolf Bjarne Kvinge [MSFT] 2015-05-27 09:02:35 UTC

*** This bug has been marked as a duplicate of bug 29211 ***