Bug 30487 - Crashes when querying HTTPS via HttpClient
Summary: Crashes when querying HTTPS via HttpClient
Status: RESOLVED DUPLICATE of bug 28398
Alias: None
Product: iOS
Classification: Xamarin
Component: BCL Class Libraries (show other bugs)
Version: 1.0
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-26 23:42 UTC by aed
Modified: 2015-08-06 05:51 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Crash console log (5.69 KB, text/plain)
2015-08-06 05:31 UTC, Alexey Bogdanov
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 28398

Description aed 2015-05-26 23:42:05 UTC
Hi - I've been getting random crashes whenever I do SSL requests. The issue appears to be in the Mono/native code. This is a simple Xamarin.Forms app that does HTTPS PostAsync requests. I am not able to consistently report it - it just happens every once in a while so I suspect it might have to do with what the server responds.

STACK TRACE:
2015-05-16 11:01:59.171 TestProgram.iOS[18452:644201] warning: mono_class_from_mono_type: implement me 0x22
2015-05-16 11:01:59.171 TestProgram.iOS[18452:644201] error: * Assertion: should not be reached at ../../../../../mono/mono/metadata/class.c:6482
2015-05-16 11:01:59.175 TestProgram.iOS[18452:644201] critical: Stacktrace:

2015-05-16 11:01:59.175 TestProgram.iOS[18452:644201] critical: at <0xffffffff>
2015-05-16 11:01:59.175 TestProgram.iOS[18452:644201] critical: at Crimson.CommonCrypto.FastCryptorTransform.InternalTransformBlock (byte[],int,int,byte[],int) [0x00095] in /Users/builder/data/lanes/1503/6481535e/source/maccore/src/CommonCrypto/FastCryptorTransform.cs:170
2015-05-16 11:01:59.175 TestProgram.iOS[18452:644201] critical: at Crimson.CommonCrypto.FastCryptorTransform.TransformBlock (byte[],int,int,byte[],int) [0x000df] in /Users/builder/data/lanes/1503/6481535e/source/maccore/src/CommonCrypto/FastCryptorTransform.cs:132
2015-05-16 11:01:59.175 TestProgram.iOS[18452:644201] critical: at Mono.Security.Protocol.Tls.CipherSuite.EncryptRecord (byte[],byte[]) [0x0008c] in //Library/Frameworks/Xamarin.iOS.framework/Versions/8.10.0.267/src/mono/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/CipherSuite.cs:307
2015-05-16 11:01:59.176 TestProgram.iOS[18452:644201] critical: at Mono.Security.Protocol.Tls.RecordProtocol.encryptRecordFragment (Mono.Security.Protocol.Tls.ContentType,byte[]) [0x00047] in //Library/Frameworks/Xamarin.iOS.framework/Versions/8.10.0.267/src/mono/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/RecordProtocol.cs:894
2015-05-16 11:01:59.176 TestProgram.iOS[18452:644201] critical: at Mono.Security.Protocol.Tls.RecordProtocol.EncodeRecord (Mono.Security.Protocol.Tls.ContentType,byte[],int,int) [0x00085] in //Library/Frameworks/Xamarin.iOS.framework/Versions/8.10.0.267/src/mono/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/RecordProtocol.cs:838
2015-05-16 11:01:59.176 TestProgram.iOS[18452:644201] critical: at Mono.Security.Protocol.Tls.RecordProtocol.EncodeRecord (Mono.Security.Protocol.Tls.ContentType,byte[]) [0x00000] in //Library/Frameworks/Xamarin.iOS.framework/Versions/8.10.0.267/src/mono/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/RecordProtocol.cs:793
2015-05-16 11:01:59.176 TestProgram.iOS[18452:644201] critical: at Mono.Security.Protocol.Tls.RecordProtocol.EncodeHandshakeRecord (Mono.Security.Protocol.Tls.Handshake.HandshakeType) [0x0000e] in //Library/Frameworks/Xamarin.iOS.framework/Versions/8.10.0.267/src/mono/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/RecordProtocol.cs:862
2015-05-16 11:01:59.177 TestProgram.iOS[18452:644201] critical: at Mono.Security.Protocol.Tls.SslClientStream.NegotiateAsyncWorker (System.IAsyncResult) [0x0022e] in //Library/Frameworks/Xamarin.iOS.framework/Versions/8.10.0.267/src/mono/mcs/class/Mono.Security/Mono.Security.Protocol.Tls/SslClientStream.cs:510
2015-05-16 11:01:59.177 TestProgram.iOS[18452:644201] critical: at (wrapper runtime-invoke) .runtime_invoke_void__this___object (object,intptr,intptr,intptr) 
2015-05-16 11:01:59.177 TestProgram.iOS[18452:644201] critical:
Comment 1 Zoltan Varga 2015-06-04 19:21:03 UTC
-> xamarin.ios.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2015-06-05 04:03:53 UTC
This may be a dup of bug #28398.

@Reporter: can you get the symbolicated crash report from Xcode (see this if you don't know how: http://jmillerdev.net/symbolicating-ios-crash-files-xamarin-ios/)?
Comment 3 aed 2015-06-10 20:46:51 UTC
Unfortunately it's unlikely I will be able to get a repro since our code base has changed significantly in the past 3 weeks. 

However, other users have gotten this error - here is the xamarin forums discussion about it: https://forums.xamarin.com/discussion/comment/127162#Comment_127162

I'll ask to see if someone is still getting it.
Comment 4 Alexey Bogdanov 2015-08-06 05:31:28 UTC
Facing exactly the same issue. Attaching console log (it was run in debugging mode on iOS simulator). Unfortunately .crash file is not available.
Comment 5 Alexey Bogdanov 2015-08-06 05:31:53 UTC
Created attachment 12377 [details]
Crash console log
Comment 6 Rolf Bjarne Kvinge [MSFT] 2015-08-06 05:51:27 UTC
This is a dup of #28398. The fix will be included in Xamarin.iOS 8.12 and 9.0 (whichever comes first).

*** This bug has been marked as a duplicate of bug 28398 ***