Bug 30456 - SqlConnectionStringBuilder does not return Password value
Summary: SqlConnectionStringBuilder does not return Password value
Status: VERIFIED DUPLICATE of bug 29823
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Data (show other bugs)
Version: 4.0.0
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-26 13:46 UTC by Cody Beyer (MSFT)
Modified: 2015-06-30 03:00 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
TestCase (5.09 KB, application/zip)
2015-05-26 13:46 UTC, Cody Beyer (MSFT)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED DUPLICATE of bug 29823

Description Cody Beyer (MSFT) 2015-05-26 13:46:04 UTC
Created attachment 11338 [details]
TestCase

### Description

When using Mono 4, SqlConnectionStringBuilder does not return a value for Password when said value is passed in the builder

### Screenshots

Here is the sample code running on against Mono 4: https://www.dropbox.com/s/r11x80iu6s278sx/Screenshot%202015-05-26%2010.30.49.png?dl=0

And here is it again against Mono 3.12: https://www.dropbox.com/s/qd67ohcotnacab8/Screenshot%202015-05-26%2010.31.00.png?dl=0

### Sample

Attached

### Steps to Reproduce

1. Download Attachment
2. Run against Mono 4

### Expected Results

SqlConnectionStringBuilder result should contain a value for Password

### Actual Results

SqlConnectionStringBuilder result does not contain a value for Password

### Version

=== Xamarin Studio ===

Version 5.9.2 (build 2)
Installation UUID: fc65f77a-6bee-473f-8adb-6b27b14a8197
Runtime:
	Mono 4.0.1 ((detached/11b5830)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400010043

=== Xamarin.Android ===

Version: 5.1.2.0 (Business Edition)
Android SDK: /Users/codybeyer/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 6.3.2 (7718)
Build 6D2105

=== Xamarin.iOS ===

Version: 8.10.1.59 (Business Edition)
Hash: 13d1cdc
Branch: master
Build date: 2015-05-18 22:54:57-0400

=== Xamarin.Mac ===

Version: 2.0.1.59 (Business Edition)

=== Build Information ===

Release ID: 509020002
Git revision: 43735a4b905b571f69cf9428a3ea7b52aef55476
Build date: 2015-05-18 09:38:12-04
Xamarin addins: ab18ddff45f507ed74f36c2b65df9aee22e28a56

=== Operating System ===

Mac OS X 10.10.3
Darwin Codys-MacBook-Pro.local 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 1 Marek Safar 2015-05-26 14:44:42 UTC

*** This bug has been marked as a duplicate of bug 29823 ***
Comment 2 Prashant manu 2015-06-30 03:00:24 UTC
We have checked with the sample attached and it is working fine with mono 4.3. Screencast: http://www.screencast.com/t/8KImYigK

Hence closing this issue. 

Environment Info:
Xamarin Studio
Version 5.10 (build 299)
Installation UUID: 642986ef-b668-4108-b6e5-f58c62d668b6
Runtime:
 Mono 4.3.0 (master/2221dfc)
 GTK+ 2.24.23 (Raleigh theme)

 Package version: 403000328

Xamarin.Profiler
Not Installed

Xamarin.Android
Version: 5.1.99.457 (Enterprise Edition)
Android SDK: /Users/360logica/Library/Developer/Xamarin/android-sdk-macosx
 Supported Android versions:
  2.3    (API level 10)
  4.0.3  (API level 15)
  4.4    (API level 19)
  4.4.87 (API level 20)
  5.0    (API level 21)
Java SDK: /usr
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

Xamarin Android Player
Version: 0.3.4
Location: /Applications/Xamarin Android Player.app

Apple Developer Tools
Xcode 6.4 (7715)
Build 6E23

Xamarin.iOS
Version: 8.11.0.1164 (Enterprise Edition)
Hash: dc19d0a
Branch: master
Build date: 2015-06-29 18:38:43-0400

Xamarin.Mac
Version: 2.1.0.1164 (Enterprise Edition)

Build Information
Release ID: 510000299
Git revision: a8391331ee54468fe238fa07a423b3b6ad229384
Build date: 2015-06-30 00:20:43-04
Xamarin addins: 1618e0996a5a331aa00d13d9d528f667a3e7912e
Build lane: monodevelop-lion-master

Operating System
Mac OS X 10.10.0
Darwin 360Logicas-MacBook-Pro.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64