Bug 30396 - Exception filters debugging does not work
Summary: Exception filters debugging does not work
Status: CONFIRMED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger (show other bugs)
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2015-05-25 04:47 UTC by Marek Safar
Modified: 2015-07-03 04:41 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 30396 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Marek Safar 2015-05-25 04:47:41 UTC
http://screencast.com/t/EhXF8L998pS

There are multiple issue
- duplicate stack entries
- step over does not step over all clauses
- catch variables are not available
- without setting a breakpoint in filter step-over or step-into does not work at all

using System;

class X
{
	static int Main ()
	{
		try {
			throw new ApplicationException ();
		} catch (Exception e) when (Foo (delegate { Console.WriteLine (e); })) {
			return 1;
		} catch (Exception e) when (e is InvalidOperationException) {
			Console.WriteLine (e);

			int paramIndex = 0;
			while (paramIndex < 3) {
				paramIndex++;
			}

			return 1;
		} catch (ApplicationException) {
			return 0;
		}
	}

	static bool Foo (Action a)
	{
		a ();
		return false;
	}
}
Comment 1 Ram Chandra 2015-05-25 14:02:52 UTC
I have checked this issue and I am also getting the same behavior

Screencast: http://www.screencast.com/t/w4KL5eWnv

IDE logs:  https://gist.github.com/RamChBachkheti/5c882d1eca83da629be5

Environment Info:

=== Xamarin Studio ===

Version 5.9.2 (build 2)
Installation UUID: 6ea47b0d-1852-4aaf-808d-373ff0a5002b
Runtime:
	Mono 4.0.1 ((detached/11b5830)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400010043

=== Apple Developer Tools ===

Xcode 6.3 (7569)
Build 6D570

=== Xamarin.iOS ===

Version: 8.10.1.64 (Enterprise Edition)
Hash: e6ebd18
Branch: master
Build date: 2015-05-21 21:55:09-0400

=== Xamarin.Android ===

Version: 5.1.2.1 (Enterprise Edition)
Android SDK: /Users/jatin66/Desktop/Backup/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.0.0.262 (Enterprise Edition)

=== Build Information ===

Release ID: 509020002
Git revision: 43735a4b905b571f69cf9428a3ea7b52aef55476
Build date: 2015-05-18 09:38:12-04
Xamarin addins: ab18ddff45f507ed74f36c2b65df9aee22e28a56

=== Operating System ===

Mac OS X 10.10.3
Darwin Dalvik.local 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 2 David Karlaš 2015-07-03 04:41:46 UTC
This has to be fixed on runtime side.