Bug 30371 - [XVS 3.11] Project Properties display incorrect default values for "BundleAssemblies" and "EmbedAssembliesIntoApk" if they are not explicitly specified
Summary: [XVS 3.11] Project Properties display incorrect default values for "BundleAss...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android (show other bugs)
Version: 3.11 (C5)
Hardware: PC Windows
: --- normal
Target Milestone: 3.11.2 (C5SR2)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-05-22 18:25 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2015-05-28 14:13 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
XVS default Android Project Properties (35.04 KB, image/png)
2015-05-22 18:25 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details
XS default Android Project Properties (26.08 KB, image/png)
2015-05-22 18:35 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2015-05-22 18:25:36 UTC
Created attachment 11305 [details]
XVS default Android Project Properties

[XVS 3.11] Project Properties display incorrect default values for "BundleAssemblies" and "EmbedAssembliesIntoApk" if they are not explicitly specified




## Regression status: REGRESSION in XVS 3.11


### Bad
Xamarin   3.11.576.0 (b28d0a1)
Xamarin.Android   5.1.2.0 (2485523223ffb88567f101866d5f73da7a37ca53)


### Bad
Xamarin   3.11.445.0 (5061f92)
Xamarin.Android   5.1.0.115 (d23da369e436488f38c8ab8fe8a9ae7d9ea5256b)


### Good
Xamarin   3.9.547.0 (20fd2f0)
Xamarin.Android   4.20.2.1 (86274adfc6418b4c3a9d67734eb871163859b51c)

Admittedly the project properties do behave strangely in XVS 3.9 in other ways, but the _precise_ problem with incorrect default values for "BundleAssemblies" and "EmbedAssembliesIntoApk" in the Debug configuration is not present.




## Steps to reproduce

1. Ensure you're using an Enterprise license.

2. Create a new "Visual C# -> Android -> Blank App (Android)" project.

3. Open "Project Properties -> Android Options".




## Contents of the default "Debug|AnyCPU" `PropertyGroup`

> <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|AnyCPU' ">
>   <DebugSymbols>true</DebugSymbols>
>   <DebugType>full</DebugType>
>   <Optimize>false</Optimize>
>   <OutputPath>bin\Debug\</OutputPath>
>   <DefineConstants>DEBUG;TRACE</DefineConstants>
>   <ErrorReport>prompt</ErrorReport>
>   <WarningLevel>4</WarningLevel>
>   <AndroidUseSharedRuntime>True</AndroidUseSharedRuntime>
>   <AndroidLinkMode>None</AndroidLinkMode>
> </PropertyGroup>




## Results


The "Packaging" tab shows checkmarks (ON) for the following settings:


- Use Shared Runtime
$(AndroidUseSharedRuntime) = True


- Bundle assemblies into native code
$(BundleAssemblies) = True


- Enable developer instrumentation (debugging and profiling)
$(DevInstrumentationEnabled) = True



The checkboxes for "BundleAssemblies" and "EmbedAssembliesIntoApk" are _wrong_. If you build and run the app, you will see that in fact "BundleAssemblies" is OFF, and "Fast deployment" is ON. So the problem is that the XVS GUI displays incorrect values for these settings unless they are explicitly specified in the `.csproj`. (As seen in the example `PropertyGroup` above, they are by default _not_ explicitly specified.)




## Expected Results

Xamarin Studio shows checkmarks (ON) for the following settings:

- Use shared Mono runtime
$(AndroidUseSharedRuntime) = True


- Fast assembly deployment
$(EmbedAssembliesIntoApk) = False


- Enable developer instrumentation (debugging and profiling)
$(DebugSymbols) = True




Note: I suspect the discrepancy between "DevInstrumentationEnabled" in XVS vs. "DebugSymbols" in XS is _not_ part of the same bug, so I will file a separate bug for that shortly.




## Additional version info

### Windows 8.1 (64-bit) in VMWare Fusion 6.0.6 (2684343) (with 2 CPU cores assigned to the VM)
Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.6.00057
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2015-05-22 18:31:26 UTC
Whoops. This is a duplicate.

*** This bug has been marked as a duplicate of bug 29148 ***
Comment 2 Brendan Zagaeski (Xamarin Team, assistant) 2015-05-22 18:34:23 UTC
Darn sorry for the noise. This is not 100% a duplicate of bug 29148. In particular, this new bug discusses an inconsistency with the "Fast assembly deployment" setting that is _not_ covered by bug 29148.

Reopening.
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2015-05-22 18:35:10 UTC
Created attachment 11306 [details]
XS default Android Project Properties
Comment 5 Emanuel 2015-05-27 13:14:17 UTC
Fixed in cycle5dev branch
wrench: ce78c701efed58b01a12f88ecd271994f2509db4
commit: b8fee5cbe637669cf6c1257d9b0e8a7994a61378
Comment 6 asimk 2015-05-28 14:13:28 UTC
I have checked this issue with build provided in Trello card and observed that it is working fine. Hence closing this issue.

Screencast: http://www.screencast.com/t/DvnNOOO6gO

Environment Info:
XVS 3.11.587 + XA 5.1.2.1
Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.6.00057


Note: I have checked this issue with previous build of C5CR1 and I am able to reproduce this issue.

Screencast: http://www.screencast.com/t/bWeogVt5Z

Environment Info:
XVS 3.11.576 + XA 5.1.2.0
Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.6.00057