Bug 30210 - Binding a TableView Title does not respond to updates
Summary: Binding a TableView Title does not respond to updates
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.4.4
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2015-05-19 03:56 UTC by Matt Whetton
Modified: 2015-08-07 07:46 UTC (History)
8 users (show)

Tags: AC
Is this bug a regression?: ---
Last known good build:


Attachments
Project reproducing error (6.51 MB, application/x-zip-compressed)
2015-05-19 03:56 UTC, Matt Whetton
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Matt Whetton 2015-05-19 03:56:20 UTC
Created attachment 11238 [details]
Project reproducing error

I have a table view which I'm trying to bind a TableSection Title property to something on my viewmodel, but it doesnt seem to work properly (i.e. it looks like it gets the binding value as its initialized, but is never updated - it also throws an exception if there is no binding value).

Also the documentation is either missing or just plain incorrect (it looks like to redirects to the ios specific documentation)
Comment 1 Chris King 2015-05-19 12:37:40 UTC
XAML binding isn't responding to update of the ViewModel.
Comment 2 Jason Smith [MSFT] 2015-08-05 15:23:18 UTC
Should be fixed in 1.5.0-pre1
Comment 3 Parmendra Kumar 2015-08-07 07:46:52 UTC
I have checked this issue with X.F 1.5.0-pre1 and its working fine at my end.

Screencast: http://www.screencast.com/t/9rBZ5rb566E


Hence closing this issue.