Bug 30200 - Listview Context Actions not closed
Summary: Listview Context Actions not closed
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.4.2
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Rui Marinho
URL:
Depends on:
Blocks:
 
Reported: 2015-05-18 14:48 UTC by Marcelo Colling
Modified: 2015-08-11 06:24 UTC (History)
8 users (show)

Tags: AC
Is this bug a regression?: ---
Last known good build:


Attachments
Reproduction (6.53 MB, application/x-zip-compressed)
2015-05-18 20:46 UTC, Chris King
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Marcelo Colling 2015-05-18 14:48:29 UTC
The Context Actions aren't closing when switching pages in masterdetailpage.
Comment 1 Chris King 2015-05-18 20:46:29 UTC
Created attachment 11237 [details]
Reproduction
Comment 2 Chris King 2015-05-18 20:47:34 UTC
Thank you for taking the time to submit the bug. Going forward, we're asking customers to attach reduced reproductions to the bugs. Ideally the reproduction would be created by starting with a clean Xamarin.Forms project and adding just the code necessary to demonstrate the issue. We know not everyone has time to do this and it's not a requirement to submit a bug but it does help us resolve issues faster as well as ensuring we're solving the same issue you're seeing so we very much appreciate it.  

Warm regards,
Xamarin Forms Team
Comment 3 Chris King 2015-05-18 20:48:37 UTC
Indeed, the menus do not close when transitioning to and from the master page. We need to decide if this is is expected or not.
Comment 4 Marcelo Colling 2015-05-19 13:12:56 UTC
The problem is when I change 'detail' of MasterDetailPage.
I have two pages(detail), and allow the transition between them
Comment 5 Marcelo Colling 2015-05-19 14:50:30 UTC
You don't need to decide what is expected or not, you can give us a choice so we do what we want. I think it's the best way.
Comment 6 Rui Marinho 2015-07-30 12:57:30 UTC
Hi Marcelo, the problem you were facing was in android right? 

Thanks
Comment 7 Marcelo Colling 2015-07-30 13:23:02 UTC
Yes, this problem occurred in Android to me, but I don't know if occurs in IOS.
Comment 8 Jason Smith [MSFT] 2015-08-03 10:49:51 UTC
Should be fixed in 1.4.5-pre1
Comment 9 Parmendra Kumar 2015-08-07 14:04:19 UTC
I have checked this issue with Xamarin.Forms 1.5.0-pre1 and observed that On Android its working fine but On iOS still getting same issue.

Screencast: http://www.screencast.com/t/WaMs2TxwZ

Hence reopened this issue with respect of iOS.


Thanks.
Comment 10 Rui Marinho 2015-08-07 19:18:05 UTC
The fix was only in Android, in IOS we don't close, this is the way the platform also works.
Comment 13 Parmendra Kumar 2015-08-11 06:24:00 UTC
Thanks @Rui

Its working fine on Android, hence closing this issue.

On iOS I have file a new bug: https://bugzilla.xamarin.com/show_bug.cgi?id=32951

Thanks.