Bug 2995 - enable Custom Command Soft Debugger in run menu
Summary: enable Custom Command Soft Debugger in run menu
Status: CONFIRMED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger (show other bugs)
Version: unspecified
Hardware: All All
: Low enhancement
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-01-20 16:46 UTC by Jonathan Shore
Modified: 2017-08-04 22:30 UTC (History)
1 user (show)

See Also:
Tags:
Is this bug a regression?: ---
Last known good build:


Attachments

Description Jonathan Shore 2012-01-20 16:46:23 UTC
The "Custom Command Soft Debugger" option can be enabled with an environment variable MONODEVELOP_SDB_TEST=1, however is not a default option and also makes "Debug" in the Run menu invoke the custom command option.

It would be nice if Debug continues to be the default local soft debugger and that there is an alternate "Debug Custom" option which allows custom command / socket based debugging.

Also with the environment variable set for Custom Command, attempting to run an executable within monodevelop can fail, indicating that is trying to connect to the soft debugger.  So something is not quite right in the mode that the environment variable creates.
Comment 1 Mikayla Hutchinson [MSFT] 2012-01-20 17:34:20 UTC
I that to allow exposing the custom soft debugger we need to use custom execution modes, like Run->Run With->Edit Custom Modes. However, I couldn't find a way to plug it into that without having it show up in the Run With menu by default.

Note You need to log in before you can comment on or make changes to this bug.