Bug 29900 - Latest Alpa Linking issus
Summary: Latest Alpa Linking issus
Status: RESOLVED DUPLICATE of bug 29866
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler (show other bugs)
Version: 5.1
Hardware: PC Windows
: --- normal
Target Milestone: 5.1.1 (C5SR1)
Assignee: Radek Doulik
URL:
Depends on:
Blocks:
 
Reported: 2015-05-09 05:21 UTC by pragma.mobilexp
Modified: 2015-05-11 17:30 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 29866

Description pragma.mobilexp 2015-05-09 05:21:59 UTC
OK, downloaded and installed the latest Alpha (3.11.546) to get the fix for the [Bug 29568](https://bugzilla.xamarin.com/show_bug.cgi?id=29568).  The fix works fine, however, I'm now getting the following issue when doing a Release build with Linking set to SDK assemblies only

```
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018: The "LinkAssemblies" task failed unexpectedly.
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018: System.InvalidOperationException: Can't not find the nested type '<System.Windows.Input.ICommand.Execute>d__4' in 'Microsoft.Practices.Prism.Commands.DelegateCommandBase
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.TypeParser.TryGetDefinition(ModuleDefinition module, Type type_info, TypeReference& type)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.TypeParser.GetTypeReference(ModuleDefinition module, Type type_info)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.TypeParser.ParseType(ModuleDefinition module, String fullname)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.SignatureReader.ReadTypeReference()
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.SignatureReader.ReadCustomAttributeElementValue(TypeReference type)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.SignatureReader.ReadCustomAttributeElement(TypeReference type)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.SignatureReader.ReadCustomAttributeFixedArgument(TypeReference type)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.SignatureReader.ReadCustomAttributeConstructorArguments(CustomAttribute attribute, Collection`1 parameters)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.MetadataReader.ReadCustomAttributeSignature(CustomAttribute attribute)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.CustomAttribute.<Resolve>m__1(CustomAttribute attribute, MetadataReader reader)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.ModuleDefinition.Read[TItem,TRet](TItem item, Func`3 read)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.CustomAttribute.Resolve()
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Cecil.CustomAttribute.get_HasConstructorArguments()
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Linker.Steps.MarkStep.MarkCustomAttributeArguments(CustomAttribute ca)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Linker.Steps.MarkStep.MarkCustomAttribute(CustomAttribute ca)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Linker.Steps.MarkStep.MarkCustomAttributes(ICustomAttributeProvider provider)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Linker.Steps.MarkStep.ProcessMethod(MethodDefinition method)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Linker.Steps.MarkStep.ProcessQueue()
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Linker.Steps.MarkStep.Process()
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Linker.Steps.MarkStep.Process(LinkContext context)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Mono.Linker.Pipeline.Process(LinkContext context)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at MonoDroid.Tuner.Linker.Process(LinkerOptions options, LinkContext& context)
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Xamarin.Android.Tasks.LinkAssemblies.Execute()
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()
17>C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(1290,5): error MSB4018:    at Microsoft.Build.BackEnd.TaskBuilder.<ExecuteInstantiatedTask>d__20.MoveNext()
```

My setup info:

Microsoft Visual Studio Premium 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.51641

Installed Version: Premium

LightSwitch for Visual Studio 2013   06191-004-0454001-02360
Microsoft LightSwitch for Visual Studio 2013

Team Explorer for Visual Studio 2013   06191-004-0454001-02360
Microsoft Team Explorer for Visual Studio 2013

Visual Basic 2013   06191-004-0454001-02360
Microsoft Visual Basic 2013

Visual C# 2013   06191-004-0454001-02360
Microsoft Visual C# 2013

Visual C++ 2013   06191-004-0454001-02360
Microsoft Visual C++ 2013

Visual F# 2013   06191-004-0454001-02360
Microsoft Visual F# 2013

Visual Studio 2013 Code Analysis Spell Checker   06191-004-0454001-02360
Microsoft® Visual Studio® 2013 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

Windows Phone SDK 8.0 - ENU   06191-004-0454001-02360
Windows Phone SDK 8.0 - ENU

.NET Portability Analyzer   1.1.10808.0
API portability analyzer.

ANTLR language support for Visual Studio   1.1
ANTLR language tools for Visual Studio includes IntelliSense and more... eventually...

ASP.NET and Web Tools   12.4.60425.0
Microsoft Web Developer Tools contains the following components:
Support for creating and opening ASP.NET web projects
Browser Link: A communication channel between Visual Studio and browsers
Editor extensions for HTML, CSS, and JavaScript
Page Inspector: Inspection tool for ASP.NET web projects
Scaffolding: A framework for building and running code generators
Server Explorer extensions for Microsoft Azure Web Apps
Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Microsoft Azure

ASP.NET Web Frameworks and Tools 2012.2   4.1.21001.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013   5.2.21010.0
For additional information, visit http://www.asp.net/

Common Azure Tools   1.4
Provides common services for use by Azure Mobile Services and Microsoft Azure Tools.

Developer Assistant   1.0
Developer Assistant puts millions of code snippets and code sample projects at your fingertips while you are coding in Visual Studio.

File Nesting   2.1.2
Automatically nest files based on file name and enables developers to nest and unnest any file manually

JetBrains ReSharper Ultimate 2015.1   Build 102.0.20150408.145317
JetBrains ReSharper Ultimate package for Microsoft Visual Studio. For more information about ReSharper Ultimate, visit http://www.jetbrains.com/resharper. Copyright © 2015 JetBrains, Inc.

Microsoft Advertising SDK for Windows Phone   
Microsoft Advertising SDK for Windows Phone
Build 

Microsoft Azure HDInsight HQL Service   2.0.1000.0
Language service for Hive query

Microsoft Azure HDInsight Tools for Visual Studio   2.0.1000.0
An integrated development environment for HDInsight application development.

Microsoft Azure Mobile Services Tools   1.3
Microsoft Azure Mobile Services Tools

Microsoft Azure Tools   2.6
Microsoft Azure Tools for Microsoft Visual Studio 2013 - v2.6.30423.1601

Microsoft Azure Tools   2.5
Microsoft Azure Tools for Microsoft Visual Studio 2013 - v2.5.21104.1601

Microsoft Team Foundation Server 2013 Power Tools   12.0
Power Tools that extend the Team Foundation Server integration with Visual Studio.

Microsoft Visual Studio Process Editor   1.0
Process Editor for Microsoft Visual Studio Team Foundation Server

Multilingual App Toolkit   4.0.1262.0
Multilingual App Toolkit helps you localize your Windows Store app by providing file management, pseudo and machine translation, translation editor, and build integration. http://go.microsoft.com/fwlink?linkid=245767

NuGet Package Manager   2.8.60318.734
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

Office Developer Tools for Visual Studio 2013 ENU   12.0.31105
Microsoft Office Developer Tools for Visual Studio 2013 ENU

OneCodeQuickLaunchPackage   1.0
Information about my package

PreEmptive Analytics Visualizer   1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

Release Management for Visual Studio Package   1.0
Release Management for Visual Studio

SAPReferenceManager   1.0
Manages References to Shared Projects

SlowCheetah - XML config transforms    1.0
This package enables you to transform your app.config or any other XML file based on the build configuration. It also adds additional tooling to help you create XML transforms.

SQL Server Data Tools   12.0.50318.0
Microsoft SQL Server Data Tools

Telerik Silverlight VSExtensions   2014.6.1124.0
Telerik UI for Silverlight VSExtensions

Telerik Windows Phone VSExtensions   2014.6.1124.0
Telerik UI for Windows Phone VSExtensions

Telerik WinForms VSExtensions   2014.6.1128.0
Telerik UI for WinForms VSExtensions

TfsGoOffline   1.0
Go Offline command

Windows Azure Tools   2.3
Windows Azure Tools for Microsoft Visual Studio 2013 - v2.3.20320.1602

Windows Phone 8.1 SDK Integration   1.0
This package integrates the tools for the Windows Phone 8.1 SDK into the menus and controls of Visual Studio.

Workflow Manager Tools 1.0   1.0
This package contains the necessary Visual Studio integration components for Workflow Manager.

Xamarin   3.11.546.0 (8fffc2e)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   5.1.1.3 (690e31db450bd2ae1517eb04840f76e23f3f6925)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS   8.10.1.0 (f6bfa6e104ce3f5a6e90f990deb176c818be2cd6)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration
Comment 1 Brendan Zagaeski (Xamarin Team, assistant) 2015-05-09 16:36:51 UTC
Thanks for the report!

To the Xamarin devs: this looks like it's most likely a duplicate of Non-Public Bug 29866?

@pragma.mobilexp, if by chance you also have a Mac with Xamarin.Android installed, one little test you could try would be to build the project on the Mac. In my very brief tests of Bug 29866, the problem seems to be specific to Windows. (That is, the problem seems to be related to the the IL that is generated by the Microsoft C# compiler on Windows. Compiling on Mac uses the Mono C# compiler, and doesn't seem to hit the problem in my tests.)


(To other users who might be seeing this, Bug 29866 is a regression between XamarinVS 3.11.445 and the new alpha version XamarinVS 3.11.546. It should be fixed before the final Beta build of the current in-progress service release.)
Comment 3 Peter Collins 2015-05-11 17:30:42 UTC
This does indeed appear to be a duplicate of #29866, and should be available in the Alpha channel within the next couple of days.

*** This bug has been marked as a duplicate of bug 29866 ***