Bug 29605 - Unable to compile iOS 8.1 App with Xamarin Studio 5.9 STABLE
Summary: Unable to compile iOS 8.1 App with Xamarin Studio 5.9 STABLE
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: MSBuild (show other bugs)
Version: XI 8.10
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2015-04-30 11:06 UTC by Neal
Modified: 2015-05-25 01:56 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Test Sample (20.83 KB, application/zip)
2015-05-04 08:36 UTC, Abhishek
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Neal 2015-04-30 11:06:37 UTC
Hello,

After upgrading to the latest stables yesterday I'm no longer able to build my iOS solution.  It builds fine in 5.8.3 but not in 5.9 with the following error:

Errors:

/Users/Neal/Dev/ncsoftware/APDL/APDL.iOS/APDL.iOS.csproj (Build) ->
/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets (_CoreCompileInterfaceDefinitions target) ->

	/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: error : Error executing tool '/Applications/Xcode.app/Contents/Developer/usr/bin/ibtool': Argument cannot be null.
Parameter name: unformatted

I tried the build in diagnostic level and no difference or any more information.  I've reviewed every XIB and Storyboard in the project in Interface Builder (Xcode 6.3.1).  This is a Unified solution.  My hunch is something has changed in the command sent to the IBTOOL between Xam Studio 5.8.3 and 5.9 which must be incorrect and causing an error such as a param/argument?

This issue is verified on 3 separate machines and as others are mentioning build issues in the Xam forums.

I'll attach the build output in a private attachment.

Thank you.

Neal

=== Xamarin Studio ===

Version 5.9 (build 431)
Installation UUID: 25d1d6a6-72c5-479c-b704-f939b8920555
Runtime:
	Mono 4.0.0 ((detached/d136b79)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000143

=== Xamarin.Android ===

Version: 5.1.0.115 (Business Edition)
Android SDK: /Users/Neal/Applications/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
Java SDK: /usr
java version "1.8.0_40"
Java(TM) SE Runtime Environment (build 1.8.0_40-b25)
Java HotSpot(TM) 64-Bit Server VM (build 25.40-b25, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Apple Developer Tools ===

Xcode 6.3.1 (7703)
Build 6D1002

=== Xamarin.iOS ===

Version: 8.10.0.267 (Business Edition)
Hash: 6481535
Branch: master
Build date: 2015-04-27 04:38:13-0400

=== Xamarin.Mac ===

Version: 2.0.0.262 (Business Edition)

=== Build Information ===

Release ID: 509000431
Git revision: 7560726734fc7267de2fa9abed2509968deefaa8
Build date: 2015-04-17 19:25:48-04
Xamarin addins: 2e772c734ab3148054eae7bf8949f340fdeb5e5e

=== Operating System ===

Mac OS X 10.10.3
Darwin iMACRH.local 14.3.0 Darwin Kernel Version 14.3.0
    Mon Mar 23 11:59:05 PDT 2015
    root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64
Comment 2 Neal 2015-04-30 11:31:32 UTC
Narrowed this down to a segue in a storyboard causing a problem - not sure why.  Turns out this storyboard is no longer used so deleting it solved the compile issue.  I'll do a private attach should anyone want to review the source should this be an issue for someone else with 5.9.
Comment 4 Jeffrey Stedfast 2015-04-30 11:54:50 UTC
Fixed in git master and a patch is ready to be merged into Xamarin.iOS 8.10.1
Comment 5 Abhishek 2015-05-01 03:25:19 UTC
I have checked this issue with master builds (Xamarin Studio 6.0 (build 488) and Xamarin.iOS 8.11.0.614) and C5 builds(Xamarin Studio 5.9 (build 459) and Xamarin.iOS
8.10.1.7) and it is getting reproduced with both builds.

Supplement Info (Master Builds)
screencast:http://www.screencast.com/t/33S75Fxaa
IDE Log: https://gist.github.com/Abhishekk360/0f5760851d264263ad85
iOS Designer Log: https://gist.github.com/Abhishekk360/97720f9de641d847d9a6
Build Output: https://gist.github.com/Abhishekk360/bab12cf16e217cf0859b

Supplement Info (C5 Builds)

Screencast:http://www.screencast.com/t/I9GxFSCinw
IDE log:https://gist.github.com/Abhishekk360/fca3ae3cd94ae5de8ed4
iOS Designer Log: https://gist.github.com/Abhishekk360/69dd88ba647d7b262b89
Build Output: https://gist.github.com/Abhishekk360/c9e295a8526e55fb54f4

Hence I am reopening this issue.Please let me know if I missed any steps.
Comment 7 Abhishek 2015-05-04 08:36:43 UTC
Created attachment 11047 [details]
Test Sample
Comment 8 Jeffrey Stedfast 2015-05-04 12:09:55 UTC
I'm not getting an error with your sample project... works fine, here.
Comment 9 Abhishek 2015-05-04 14:05:34 UTC
I have checked this issue again on another machine and I am able to reproduce it with the current stable build of XI : 8.10.0.267
and the master build : monotouch-8.11.0.663_6d7c86d60b662e4565a87d34351c69e3ea33ceac is working fine.

screencast : http://www.screencast.com/t/dvk0bbUu

Hence closing this issue.
Comment 10 Abhishek 2015-05-05 05:32:28 UTC
I have also checked this issue with C5 build:
monotouch-8.10.1.24_1b48440fff08f5e0e36511f1f7b1f620c05ccd61 and this issue is working fine .
Here is the screencast for the same: http://www.screencast.com/t/F5CFlegr
Comment 11 Saurabh 2015-05-25 01:56:00 UTC
I have checked this Issue with latest X.iOS build and build the attached project. Application builds successfully.

Build Output: https://gist.github.com/saurabh360/51b5e861df57e457c391

Build Output:
=== Xamarin Studio ===

Version 5.9.1 (build 3)
Installation UUID: 0b7eaebc-a0ed-4b58-81df-91e378cad28c
Runtime:
	Mono 4.0.0 ((detached/d136b79)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000143

=== Apple Developer Tools ===

Xcode 6.3.2 (7718)
Build 6D2105

=== Xamarin.iOS ===

Version: 8.10.0.304 (Enterprise Edition)
Hash: 05ccd89
Branch: master
Build date: 2015-05-22 14:39:01-0400

=== Xamarin.Android ===

Version: 5.1.1.0 (Enterprise Edition)
Android SDK: /Users/Admin_Mac/Desktop/Anddk/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.0.0.262 (Enterprise Edition)

=== Build Information ===

Release ID: 509010003
Git revision: aad75a6e7e48f18120ce41f47d0ff2c6216f49c3
Build date: 2015-05-08 12:46:18-04
Xamarin addins: 1246b3044cbb7f56a217334f8fc5489ef8eefe3f

=== Operating System ===

Mac OS X 10.10.2
Darwin Admin-Macs-Mac-mini.local 14.1.0 Darwin Kernel Version 14.1.0
    Thu Nov 13 18:36:56 PST 2014
    root:xnu-2782.10.65~2/RELEASE_X86_64 x86_64