Bug 29466 - [mono] System.MissingMethodException: Method not found: 'Android.Runtime.JNIEnv.StartCreateInstance'.
Summary: [mono] System.MissingMethodException: Method not found: 'Android.Runtime.JNIE...
Status: RESOLVED ANSWERED
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries (show other bugs)
Version: 5.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2015-04-28 10:34 UTC by sunil.rana
Modified: 2015-05-12 12:13 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description sunil.rana 2015-04-28 10:34:28 UTC
[mono] System.MissingMethodException: Method not found: 'Android.Runtime.JNIEnv.StartCreateInstance'.
Comment 1 Jonathan Pryor 2015-04-28 11:46:10 UTC
Please provide a complete repro project.
Comment 2 Jonathan Pryor 2015-05-12 12:13:14 UTC
This is *probably* caused by using a Java Library Binding project built against Xamarin.Android 5.1 with an Application project being built against Xamarin.Android 4.20.

XA 5.1 binding assemblies are not compatible with XA 4.20. XA 4.20 binding assemblies *are* compatible with XA 5.1.