Bug 29266 - Android.Content.Res.Resources+NotFoundException: Resource ID #0xff303030
Summary: Android.Content.Res.Resources+NotFoundException: Resource ID #0xff303030
Status: RESOLVED DUPLICATE of bug 29267
Alias: None
Product: Forms
Classification: Xamarin
Component: Android (show other bugs)
Version: 1.4.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-04-21 04:33 UTC by buddylove_123
Modified: 2015-04-21 04:41 UTC (History)
0 users

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 29267

Description buddylove_123 2015-04-21 04:33:26 UTC
I created an empty POL Xamarin Forms project and added the following in the App constructor

        var TabbedPages = new TabbedPage { Title = "Test App" };
        MainPage = new NavigationPage(TabbedPages);
Then in the LoadApplication(new App()); line I get the following exception

Android.Content.Res.Resources+NotFoundException: Resource ID #0xff303030

I've attached my test project, please run within Visual Studio and enable the check box 'thrown' for Exception 'Common Language Runtime Exceptions' in the Debug->Exceptions dialog.

Please note I also get the error when I do the following which means the issue is with the NavigationPage.

        MainPage = new NavigationPage(new ContentPage());
When I do the following, then it works.
MainPage = new ContentPage();

Also reproduced the error with the Forms2Native sample project.
Comment 1 buddylove_123 2015-04-21 04:41:59 UTC

*** This bug has been marked as a duplicate of bug 29267 ***