Bug 28833 - Does not handle national characters
Summary: Does not handle national characters
Status: RESOLVED DUPLICATE of bug 14918
Alias: None
Product: Android
Classification: Xamarin
Component: General (show other bugs)
Version: 5.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2015-04-07 05:41 UTC by Þórður
Modified: 2015-04-10 17:40 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 14918

Description Þórður 2015-04-07 05:41:37 UTC
My default Windows 8.1 profile is linked to my ms account, and windows then creates my profile with icelandic characters.  This causes problems for Xamarin Studio, as it can't handle non-english characthers, in my case "Þ,ó,ð" from my first name "Þórður".

Projects can not be built in the default projects directory (error 675):

C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2,2): Error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.UnauthorizedAccessException: Access to the path "C:\Users\Þórður" is denied. (XA0000) (test1.Droid)


If I place the projects somewhere 'safe' (c:\dev), then next problem: the android emulators can not be started:

C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(3,3): Error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: Could not find SDK directory 'C:\Users\Þórð
ur\AppData\Local\Android\android-sdk'.  Is --sdk-dir set appropriately? (XA0000) (TaskyAndroid)

If I somehow get the emulator started, then the next error is in locating the SDK directory:

C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(3,3): Error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: Could not find SDK directory 'C:\Users\Þórður\AppData\Local\Android\android-sdk'.  Is --sdk-dir set appropriately? (XA0000) (TaskyAndroid)
Comment 1 Þórður 2015-04-07 05:48:43 UTC
edit - 
1- project can not be compiled if their path contains non-english chars
2 - emulator does not start
3 - if emulator is started manually, access to sdk fails because of non-english chars in path.
Comment 2 Jonathan Pryor 2015-04-10 17:40:29 UTC

*** This bug has been marked as a duplicate of bug 14918 ***