Bug 28765 - Slider Value property binds OneWay by default
Summary: Slider Value property binds OneWay by default
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.4.1
Hardware: Macintosh Mac OS
: Normal minor
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-04-04 07:03 UTC by Ed
Modified: 2015-06-18 13:30 UTC (History)
6 users (show)

Tags: functional binder AC
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Ed 2015-04-04 07:03:25 UTC
Slider Value property binds OneWay by default, which is counterintuitive. What makes sense is to have it bind TwoWay by default.
Comment 1 Rajneesh Kumar 2015-05-01 13:05:44 UTC
Hi Ed,
I have checked this issue using the sample provided in another Bug 28764 , and I observed that 
setting Value property binds OneWay or leaving blank I am not getting any output in application output. However when I set it to TwoWay I am getting output. Please have a look on the screencast : http://www.screencast.com/t/0eT9lXCx

So I observed that Slider Value property binds OneWay by default and I am able to move slide in both way. 
Please let me confirmed about this behaviour also confirmed that I have checked this issue in a Right way? If no the please let me know that what steps should I follow to reproduce this issue? That would be very helpful to reproduce this issue at our end.

Thanks..!

Environment Info:

Xamarin.Forns Version: 1.4.3.6358-pre2

 === Xamarin Studio ===

Version 5.9 (build 457)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
	Mono 4.0.1 ((detached/ed6b20e)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400010023

=== Apple Developer Tools ===

Xcode 6.2 (6776)
Build 6C131e

=== Xamarin.iOS ===

Version: 8.10.1.7 (Business Edition)
Hash: 23d069f
Branch: master
Build date: 2015-04-30 21:54:37-0400

=== Xamarin.Android ===

Version: 5.1.0.120 (Business Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.3    (API level 10)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		5.0    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.0.1.7 (Business Edition)

=== Build Information ===

Release ID: 509000457
Git revision: c27961c1dcfe2f8b5e5bb525c5dff33ce18a873c
Build date: 2015-04-30 19:35:14-04
Xamarin addins: df9b5918c9f7aca6da509fe3e5a62553aa101910

=== Operating System ===

Mac OS X 10.9.5
Darwin MacMini.local 13.4.0 Darwin Kernel Version 13.4.0
    Sun Aug 17 19:50:11 PDT 2014
    root:xnu-2422.115.4~1/RELEASE_X86_64 x86_64
Comment 2 Ed 2015-05-01 13:07:58 UTC
Yes, i confirm. The problem is that Slider Value's default binding is OneWay, while it should be TwoWay by default.
Comment 3 Rajneesh Kumar 2015-05-01 13:16:20 UTC
Thanks a lot Ed, for clarification and  confirmation of issue. 

So as per comment 2 "The problem is that Slider Value's default binding is OneWay, while it should be TwoWay by default." Changing its status from needinfo to confirmed.

Thanks..!
Comment 4 Jason Smith [MSFT] 2015-06-11 16:49:07 UTC
Should be fixed in 1.4.3 final
Comment 5 Parmendra Kumar 2015-06-18 13:30:24 UTC
I have checked this issue with xamarin.forms.1.4.3.6364-pre3 and its working fine at my end.

Screencast: http://www.screencast.com/t/4NJIAIlbcjpP

Hence closing this issue.

Environment info:

Xamarin Studio 5.9.3 (build 1)
Installation UUID: 1a096c6f-0678-402e-89b2-a2c10f7e80e4
Mono 4.0.1 ((detached/ed1d3ec)
GTK+ 2.24.23 (Raleigh theme)
Package version: 400010044
Xcode 6.2 (6776)
Build 6C131e
Xamarin.iOS : 8.10.1.64 (Enterprise Edition)
Xamarin.Android : 5.1.3.1 (Enterprise Edition)
Xamarin.Mac : 2.0.1.64 (Enterprise Edition)
Mac OS X 10.9.4