Bug 28717 - GlobalFilterCollection missing in System.Web.Mvc.dll
Summary: GlobalFilterCollection missing in System.Web.Mvc.dll
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Web (show other bugs)
Version: master
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-04-03 03:00 UTC by Sam
Modified: 2015-04-14 10:35 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 28717 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Sam 2015-04-03 03:00:59 UTC
New MVC project cannot be compiled for following error: Global.asax.cs(44,44): Error CS0246: The type or namespace name `GlobalFilterCollection' could not be found. Are you missing an assembly reference? (CS0246) (Xablock) Usings: using System.Web.Routing; using System.Web.Mvc; using System.Web; Arch Linux - installation of MonoDevelop was after system upgrade. It shows version "5.7.1" - not "4.0.0". And a try .NET compiler + Mono - 4.5, 4, 4 CP.