Bug 28662 - SqlDataReader.GetFieldValue<T> overrides base implementation that would work and throws
Summary: SqlDataReader.GetFieldValue<T> overrides base implementation that would work ...
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Data (show other bugs)
Version: 3.12.0
Hardware: All All
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2015-04-01 15:26 UTC by Rowan Miller
Modified: 2018-02-22 22:36 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Rowan Miller 2015-04-01 15:26:41 UTC
DbDataReader.GetFieldValue<T> was implemented recently https://github.com/mono/mono/blob/mono-3.12.1/mcs/class/System.Data/System.Data.Common/DbDataReader.cs#L192

However it looks like historically SqlDataReader.GetFieldValue<T> was setup to throw a NotImplementedException and this was not removed when the base implementation was added https://github.com/mono/mono/blob/master/mcs/class/System.Data/System.Data.SqlClient/SqlDataReader.cs#L1410

This blocks usage of GetFieldValue<T> on SqlServer, but just removing the overload would allow the base implementation to be used.
Comment 1 Marek Safar 2018-02-22 22:36:08 UTC
Mono 5.10 has significantly improved System.Data implementation which should resolve this issue. If you can still reproduce it please reopen the issue.