Bug 28650 - In a Listview on iOS, "andExpand" does not expand when text is two lines long
Summary: In a Listview on iOS, "andExpand" does not expand when text is two lines long
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms (show other bugs)
Version: 1.4.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
: 33841 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-01 14:32 UTC by christine.blanda
Modified: 2017-01-12 20:07 UTC (History)
10 users (show)

See Also:
Tags: AC
Is this bug a regression?: ---
Last known good build:


Attachments
test project (88.38 KB, application/x-zip-compressed)
2015-04-01 14:41 UTC, christine.blanda
Details
new recreation of the issue (7.77 MB, application/x-zip-compressed)
2016-04-27 16:48 UTC, christine.blanda
Details

Description christine.blanda 2015-04-01 14:32:27 UTC
Run that attached project , open the MasterDetail Menu.  (The colors are to help identify the issue)  The title and description for Item Two do not expand, resulting in the carrot not lining up.
Comment 1 christine.blanda 2015-04-01 14:41:47 UTC
Created attachment 10590 [details]
test project
Comment 2 Arpit Jha 2015-04-27 02:44:09 UTC
I have checked this issue and observed that nugget file is missing in test project that you attached.
I tried to restore the package, package restored successfully  and getting nugget file missing.
Could you please add the updated test project with nugget file, So that we can reproduce at our end.

Screencast: http://www.screencast.com/t/aoQKTMoRE


Environment Info:
=== Xamarin Studio ===

Version 5.9 (build 436)
Installation UUID: 3d25a767-a003-4a7d-9f5e-e57987cf6cf0
Runtime:
	Mono 4.0.0 ((detached/fd35b80)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 400000145

=== Apple Developer Tools ===

Xcode 6.3 (7569)
Build 6D570

=== Xamarin.iOS ===

Version: 8.10.0.266 (Trial Edition)
Hash: c8648f0
Branch: master
Build date: 2015-04-21 12:22:24-0400

=== Xamarin.Android ===

Version: 5.1.0.115 (Trial Edition)
Android SDK: /Users/mac360_xamarin/Library/Developer/Xamarin/android-sdk-macosx
	Supported Android versions:
		2.3   (API level 10)
		4.0.3 (API level 15)
		4.4   (API level 19)
		5.0   (API level 21)
Java SDK: /usr
java version "1.7.0_71"
Java(TM) SE Runtime Environment (build 1.7.0_71-b14)
Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

=== Xamarin Android Player ===

Version: Unknown version
Location: /Applications/Xamarin Android Player.app

=== Xamarin.Mac ===

Version: 2.1.0.614 (Starter Edition)

=== Build Information ===

Release ID: 509000436
Git revision: 7e8ba4cbccf7b188ce5e80a90fdc4acdedb5a83f
Build date: 2015-04-23 13:19:57-04
Xamarin addins: 21fd95f743742c5237e22023996c2800ce3f8db3

=== Operating System ===

Mac OS X 10.10.0
Darwin mac360-xamarins-Mac-mini.local 14.0.0 Darwin Kernel Version 14.0.0
    Fri Sep 19 00:26:44 PDT 2014
    root:xnu-2782.1.97~2/RELEASE_X86_64 x86_64
Comment 3 christine.blanda 2015-04-27 07:16:49 UTC
This is the same text project as bug #28654 and that one worked, try using that text project.
Comment 4 Arpit Jha 2015-04-27 08:31:14 UTC
Thanks  @christine, I have checked this issue and 
getting same behaviour as mentioned in bug description with the help of attached project.

Screencast: http://www.screencast.com/t/zSx4AtSnkx
VS Ide log: https://gist.github.com/Arpit360/1fd7ca436aa566fa4474

Environment Info:
Xamarin.Forms 1.4.2.6355
XI 8.10.0.266 || Build Host :3.11.0.446
Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.51641

Installed Version: Professional
Xamarin   3.11.448.0 (e8d1103)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   5.1.0.115 (d23da369e436488f38c8ab8fe8a9ae7d9ea5256b)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS   8.10.0.0 (7741cc495ab0baf04ff0405d0604bc27f0ecae2e)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration
Comment 5 christine.blanda 2016-04-27 16:48:25 UTC
Created attachment 15858 [details]
new recreation of the issue

Here is the test project that we used in the one-on-one at evolve
Comment 6 christine.blanda 2016-08-29 15:19:45 UTC
Any update on this?
Comment 7 Paul DiPietro [MSFT] 2016-11-15 02:54:05 UTC
*** Bug 33841 has been marked as a duplicate of this bug. ***
Comment 8 Thibault Durand 2016-11-15 07:21:09 UTC
Despite the title of the issue, the label does not need to be in a ListView for this bug to appear. (see #33841)
Comment 9 Samantha Houts [MSFT] 2016-11-15 18:39:39 UTC
https://github.com/xamarin/Xamarin.Forms/pull/529
Comment 10 Rui Marinho 2017-01-12 20:07:51 UTC
Should be fixed in next 2.3.4-pre1

Note You need to log in before you can comment on or make changes to this bug.