Bug 28337 - Mono (Banshee) crashes on OpenBSD 5.7-current.
Summary: Mono (Banshee) crashes on OpenBSD 5.7-current.
Status: RESOLVED NORESPONSE
Alias: None
Product: Runtime
Classification: Mono
Component: General (show other bugs)
Version: 3.12.0
Hardware: PC Other
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on: 28690
Blocks:
  Show dependency tree
 
Reported: 2015-03-23 13:55 UTC by sam
Modified: 2018-04-05 19:44 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description sam 2015-03-23 13:55:42 UTC
Hello,

Mono crashes every time I try to run Banshee.

I am running on OpenBSD 5.7-current, and trying to run Mono. 
I have installed both mono and banshee from the ports.
I have attached a generated core file created as a result of the segfault.

Mono JIT compiler version 3.12.0 (tarball Thu Mar 19 20:27:32 MDT 2015)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           normal
        SIGSEGV:       altstack
        Notification:  kqueue
        Architecture:  amd64
        Disabled:      none
        Misc:          softdebug 
        LLVM:          supported, not enabled.
        GC:            Included Boehm (with typed GC and Parallel Mark)

$ banshee 
[Warn  17:51:53.962] DBus support could not be started. Disabling for this session. - System.Exception: Error 47: Address family not supported by protocol family (in `dbus-sharp')
  at DBus.Unix.UnixSocket.Connect (System.Byte[] remote_end) [0x00000] in <filename unknown>:0 
  at DBus.Transports.UnixNativeTransport.OpenUnix (System.String path) [0x00000] in <filename unknown>:0 
  at DBus.Transports.UnixNativeTransport.Open (System.String path, Boolean abstract) [0x00000] in <filename unknown>:0 
  at DBus.Transports.UnixTransport.Open (DBus.AddressEntry entry) [0x00000] in <filename unknown>:0 
  at DBus.Transports.Transport.Create (DBus.AddressEntry entry) [0x00000] in <filename unknown>:0 
  at DBus.Connection.OpenPrivate (System.String address) [0x00000] in <filename unknown>:0 
  at DBus.Connection..ctor (System.String address) [0x00000] in <filename unknown>:0 
  at DBus.Bus..ctor (System.String address) [0x00000] in <filename unknown>:0 
  at DBus.Bus.Open (System.String address) [0x00000] in <filename unknown>:0 
  at DBus.Bus.get_System () [0x00000] in <filename unknown>:0 
System.Exception: Unable to open the system message bus. (in `dbus-sharp')
  at DBus.Bus.get_System () [0x00000] in <filename unknown>:0 
  at DBus.BusG.Init () [0x00000] in <filename unknown>:0 
  at Banshee.ServiceStack.DBusConnection.Connect (System.String serviceName, Boolean init) [0x00000] in <filename unknown>:0 
  at Banshee.ServiceStack.DBusConnection.GrabDefaultName () [0x00000] in <filename unknown>:0 
[Info  17:51:54.919] Running Banshee 2.6.2: [OpenBSD Ports (openbsd5.7, x86_64) @ 2015-03-20 18:15:36 MDT]
Can't find custom attr constructor image: /usr/local/lib/mono/gac/Mono.Addins/1.0.0.0__0738eb9f132ed756/Mono.Addins.dll mtoken: 0x0a0002ac
* Assertion at class.c:5697, condition `!mono_loader_get_last_error ()' not met

Stacktrace:

  at <unknown> <0xffffffff>
  at Banshee.ServiceStack.ServiceManager.DefaultInitialize () <0x0001d>
  at Banshee.ServiceStack.Application.Initialize () <0x00010>
  at Banshee.Gui.GtkBaseClient.Initialize (bool) <0x00055>
  at Banshee.Gui.GtkBaseClient..ctor (bool,string) <0x00039>
  at Banshee.Gui.GtkBaseClient..ctor () <0x00023>
  at Nereid.Client..ctor () <0x00014>
  at (wrapper runtime-invoke) object.runtime_invoke_void__this__ (object,intptr,intptr,intptr) <0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.Reflection.MonoCMethod.InternalInvoke (System.Reflection.MonoCMethod,object,object[],System.Exception&) <0xffffffff>
  at System.Reflection.MonoCMethod.InternalInvoke (object,object[]) <0x00045>
  at System.Activator.CreateInstance (System.Type,bool) <0x00186>
  at System.Activator.CreateInstance (System.Type) <0x00016>
  at Banshee.Gui.GtkBaseClient.Startup () <0x00021>
  at Hyena.Gui.CleanRoomStartup.Startup (Hyena.Gui.CleanRoomStartup/StartupInvocationHandler) <0x000ae>
  at Banshee.Gui.GtkBaseClient.Startup<T> () <0x000cb>
  at Banshee.Gui.GtkBaseClient.Startup<T> (string[]) <0x0014a>
  at Nereid.Client.Main (string[]) <0x00022>
  at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>
  at <unknown> <0xffffffff>
  at (wrapper managed-to-native) System.AppDomain.ExecuteAssembly (System.AppDomain,System.Reflection.Assembly,string[]) <0xffffffff>
  at System.AppDomain.ExecuteAssemblyInternal (System.Reflection.Assembly,string[]) <0x00043>
  at System.AppDomain.ExecuteAssembly (string,System.Security.Policy.Evidence,string[]) <0x00044>
  at (wrapper remoting-invoke-with-check) System.AppDomain.ExecuteAssembly (string,System.Security.Policy.Evidence,string[]) <0xffffffff>
  at System.AppDomain.ExecuteAssembly (string) <0x00024>
  at (wrapper remoting-invoke-with-check) System.AppDomain.ExecuteAssembly (string) <0xffffffff>
  at Booter.Booter.BootClient (string) <0x00092>
  at Booter.Booter.Main () <0x0027c>
  at (wrapper runtime-invoke) object.runtime_invoke_void (object,intptr,intptr,intptr) <0xffffffff>

=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Abort trap (core dumped)
Comment 1 Zoltan Varga 2015-03-25 01:35:44 UTC
The problem is this line:
Can't find custom attr constructor image:
/usr/local/lib/mono/gac/Mono.Addins/1.0.0.0__0738eb9f132ed756/Mono.Addins.dll
mtoken: 0x0a0002ac
This is probably caused my a missing/mismatched assembly version.
Comment 2 Rodrigo Kumpera 2015-04-02 11:44:33 UTC
The crash should go away once we're done with the loader error transition.
Comment 3 Ludovic Henry 2018-02-28 23:59:49 UTC
Can you still reproduce with latest version of Mono? If so please provide a test case so we can try to reproduce locally. Thank you.
Comment 4 Ludovic Henry 2018-04-05 19:44:09 UTC
Please reopen if you can still reproduce. Thank you