Bug 28235 - System.Type change to reference source broke IronPython
Summary: System.Type change to reference source broke IronPython
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: mscorlib (show other bugs)
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2015-03-20 08:13 UTC by Piotr Zierhoffer
Modified: 2015-03-20 12:39 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Example that fails. (2.63 KB, text/x-csharp)
2015-03-20 08:13 UTC, Piotr Zierhoffer
Details
complete project with precompiled binaries (1.29 MB, application/gzip)
2015-03-20 08:18 UTC, Piotr Zierhoffer
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Piotr Zierhoffer 2015-03-20 08:13:12 UTC
Created attachment 10424 [details]
Example that fails.

Git commit 5ecee9a0c835bb4a5f6f2723bc4d6af9a42da70d (and 8057adf2e8498b0ca0aa63463c16e34910a2651d fixing the build), found by git bisect, that introduced System.Type from reference sources broke something, I believe, in DLR.

My error occurred in IronPython library.

I am unable to create a minimal example of the bug, because Microsoft.Scripting is terra incognita for me, but I have managed to create a minimal example with IronPython.

The attached code, referencing the newest IronPython from https://github.com/IronLanguages/main, works both on .NET and on Mono a53e9778b33f1de82ea4639ef18f6ae9852d5534.

Required libraries from IronLanguages:
IronPython.dll
Microsoft.Dynamic.dll
Microsoft.Scripting.dll
Microsoft.Scripting.Metadata.dll

On later versions of Mono the error is:

System.MissingMemberException
'NullImporter' object has no attribute 'find_module'

(there is such a class in IronPython, with 'find_module' method)

I will also attach a full tar.gz with sources and compiled required libraries.
Comment 1 Piotr Zierhoffer 2015-03-20 08:18:23 UTC
Created attachment 10426 [details]
complete project with precompiled binaries
Comment 2 Marek Safar 2015-03-20 08:49:46 UTC
This looks like duplicate of  #28184. Please could you retest with #28184 fixed?
Comment 3 Piotr Zierhoffer 2015-03-20 09:13:27 UTC
I have tested on 2c95d347b6f1d3c0de92f35b60b266f446f33690 (the current HEAD), same wrong results.
Comment 4 Marek Safar 2015-03-20 12:39:34 UTC
Fixed in master